C115 loader.compalram.bin

list_mailing at libero.it list_mailing at libero.it
Fri Jan 14 17:06:35 UTC 2011


Hello.
I'm trying to load the loader.compalram.bin. 
The behaviour is very strange because sometimes the download is complete and 
successfull, sometimes; in particular, in this case, the download is complete, 
but any ACK is sent back from the mobile phone (see below). 
./osmocon -p /dev/ttyUSB0 -m c123 ../..
/target/firmware/board/compal_e99/loader.compalram.bin
got 2 bytes from modem, data looks like: 2e c8  ..
got 5 bytes from modem, data looks like: 1b f6 02 00 41  ....A
got 1 bytes from modem, data looks like: 01  .
got 1 bytes from modem, data looks like: 40  @
Received PROMPT1 from phone, responding with CMD
read_file(../../target/firmware/board/compal_e99/loader.compalram.bin): 
file_size=21752, hdr_len=4, dnload_len=21759
got 1 bytes from modem, data looks like: 1b  .
got 1 bytes from modem, data looks like: f6  .
got 1 bytes from modem, data looks like: 02  .
got 1 bytes from modem, data looks like: 00  .
got 1 bytes from modem, data looks like: 41  A
got 1 bytes from modem, data looks like: 02  .
got 1 bytes from modem, data looks like: 43  C
Received PROMPT2 from phone, starting download
handle_write(): 4096 bytes (4096/21759)
handle_write(): 4096 bytes (8192/21759)
handle_write(): 4096 bytes (12288/21759)
handle_write(): 4096 bytes (16384/21759)
handle_write(): 4096 bytes (20480/21759)
handle_write(): 1279 bytes (21759/21759)
handle_write(): finished


The target phone is C115. I tried compal_exx and the result is the same :-(

Please, can someone help me to understand the reasons?
Thanks in advance.





More information about the baseband-devel mailing list