Problem compiling OsmocomBB on BT4 RC2

Holger Hans Peter Freyther holger at freyther.de
Mon Jan 17 16:26:38 UTC 2011


On 01/17/2011 05:20 PM, quem tu quiseres wrote:
> Hi again,
> 
> In case anyone was wondering, I had libtool installed but for some reason it wasn't working right when compiling so I reinstalled it, deleted the osmocom branch and started over from scratch. This time it worked without a problem and i managed to get layer21 up and running on my C115. So if you get similar error messages I recommend deleting and starting over from scratch.
> Now I tried to play around with sylvain's testing branch and I'm getting compile errors. I know this is a bit long to post here but maybe someone here knows what these errors are all about. You can see that the errors begin with the simtest app:
> 
> rm-elf-gcc -mcpu=arm7tdmi -Iinclude/ -I../../../include -I../../shared/libosmocore/include -Wall -Wextra -Wcast-align -Wimplicit -Wunused -Wswitch -Wredundant-decls -Wreturn-type -Wshadow -Wnested-externs -Wbad-function-cast -Wsign-compare -Waggregate-return -Os -ffunction-sections -gdwarf-2 -DGIT_REVISION=\"osmocon_v0.0.0-756-g999254a-modified\" -DCONFIG_TX_ENABLE -DCONFIG_FLASH_WRITE -Wa,-adhlns=apps/simtest/main.lst -c -o apps/simtest/main.o apps/simtest/main.c
> apps/simtest/main.c:161: error: parse error before '<<' token
> apps/simtest/main.c:168: error: parse error before numeric constant



this is not C++... so you have a merge error... on the merge you did... fix
the merge error...




More information about the baseband-devel mailing list