C123 crashing (?)

Harald Welte laforge at gnumonks.org
Thu Mar 11 20:14:15 UTC 2010


Hi Patrick,

good to have you on board!

On Thu, Mar 11, 2010 at 07:19:04PM +0100, Patrick McHardy wrote:

> I'm trying to run the layer1 firmware and the layer23 program
> with an C123, however as soon as the firmware reports a layer 1
> reset and a L1CTL_NEW_CCCH_REQ message is sent to the phone,
> it appears to crash and sends a new PROMPT1, causing an endless
> cycle of firmware uploads and following crashes.

that's something I haven't seen so far yet.  Are you using the C123 that
I shipped you (i.e. from the same batch as those I and others use), or
was it obtained somewhere else?  In the latter case, it might be some
different hardware version or the like.  So far I haven't yet seen any
differences, but well, what do we know about what the manufacturer did.

btw: What about the l1test.bin.  This one does a scan over the GSM900
band and then automatically selects the strongest ARFCN (and sends DATA
INDICATIONS to the layer23).

> Any hints how to debug this further?

At this point I would say try to eliminate differences to other
developers, i.e. what particular toolchain are you using?  Can you try
a layer1.bin compiled by somebody else, just to determine if its
something in the build or something related to your hardware that
we're not doing right yet.

Just my 2 cents from holidays,
	Harald

-- 
- Harald Welte <laforge at gnumonks.org>           http://laforge.gnumonks.org/
============================================================================
"Privacy in residential applications is a desirable marketing option."
                                                  (ETSI EN 300 175-7 Ch. A6)




More information about the baseband-devel mailing list