Getting Started..

Dieter Spaar spaar at mirider.augusta.de
Tue Mar 2 08:13:48 UTC 2010


Hello Thomas,

On Mon, 01 Mar 2010 23:45:43 +0100, "Thomas Kindler" <mail+gsm at t-kindler.de> wrote:

> What do I do wrong?

There is probably something wrong with your cable or configuration.
I have marked the lines below in your log, the marked bytes are the
"download command" sent by osmocon. Those bytes are never echoed back
by the bootloader and you should not see them. So you should first check
why you see those bytes.

> got 2 bytes from modem, data looks like: 04 81
> got 5 bytes from modem, data looks like: 1b f6 02 00 41
> got 1 bytes from modem, data looks like: 01
> got 1 bytes from modem, data looks like: 40
> Received PROMPT1 from phone, responding with CMD
> read_file(../../target/firmware/hello_world.bin): file_size=16676, 
> hdr_len=4, dnload_len=16683
> got 1 bytes from modem, data looks like: 1b <<- should not be there
> got 1 bytes from modem, data looks like: f6 <<- should not be there
> got 1 bytes from modem, data looks like: 02 <<- should not be there
> got 1 bytes from modem, data looks like: 00 <<- should not be there
> got 1 bytes from modem, data looks like: 52 <<- should not be there
> got 1 bytes from modem, data looks like: 01 <<- should not be there
> got 1 bytes from modem, data looks like: 53 <<- should not be there
> got 1 bytes from modem, data looks like: 66
> got 1 bytes from modem, data looks like: 74
> got 1 bytes from modem, data looks like: 6d
> ...

Best regards,
  Dieter
-- 
Dieter Spaar, Germany                           spaar at mirider.augusta.de




More information about the baseband-devel mailing list