Some refactoring proposals
246tnt at gmail.com
Tue Jul 27 19:02:02 UTC 2010
>> * Split layer23/src into
>> - common: what makes liblayer23, purely generic stuff that needs
>> binding together to define an app
>> - mobile: The real complete mobile application
>> - misc: The test applications and their support code layer23 (which
>> I'd rename bcch_dump since that's what it does), echo_test, bcch_scan)
> Sounds fine with me. If Andreas doesn't mind, I'm happy to merge a branch
> containing this split
Ok, this is done. It's waiting in my pending branch with a bunch of
other fixes. It requires a libosmocore update as well.
(I moved a func to libosmocore, which required to update it, which
bringed the msgb checks, which broke the target build and required
fixing, it also showed some bugs in fw and layer23 code that required
fixing as well ...)
The L1CTL stuff is next and then the test apps.
The lapdm will probably wait as I don't have an immediate need for it.
More information about the baseband-devel