problem to install gr-osmosdr

alberto.alletto at alice.it alberto.alletto at alice.it
Fri Apr 9 16:33:10 UTC 2021


 Hi to all!I'm new on ubuntu world...but I need to install gnuradio ..
I am following a guide:
sudo apt-get install python3-pip

sudo pip3 install pybombs

pybombs auto-config

pybombs recipes add-defaults

pybombs prefix init ~/prefix-3.8 -R gnuradio-default

source ~/prefix-3.8/setup_env.sh
....and that is all fine.

Finally I installed gr-osmosdr:

pybombs install gr-osmosdr
but i have a problem:


...
Clone in 'gr-iqbal' in corso...
Configuring: (100%) [=========================================================]
[WARNING] Configuration failed. Re-trying with higher verbosity.
CMake Error at CMakeLists.txt:32 (find_package):
  Could not find a configuration file for package "Gnuradio" that is
  compatible with requested version "3.9".

  The following configuration files were considered but not accepted:

    /home/alberto/prefix-3.8/lib/cmake/gnuradio/GnuradioConfig.cmake, version: 3.8.3.git

....

-- Configuring incomplete, errors occurred!
See also "/home/alberto/prefix-3.8/src/gr-iqbal/build/CMakeFiles/CMakeOutput.log".
[ERROR] Configuration failed after running at least twice.
[ERROR] Problem occurred while building package gr-iqbal:
Configuration failed
[ERROR] Error installing package gr-iqbal. Aborting.
alberto at alberto-Studio-XPS-1340:~$



How i can solve this problem ?
tnx,
Alberto



Entire process:
alberto at alberto-Studio-XPS-1340:~$ pybombs install gr-osmosdr
[INFO] Prefix Python version is: 3.8.5
[INFO] PyBOMBS Version 2.3.4
[INFO] Phase 1: Creating install tree and installing binary packages:
[INFO] Executing command with elevated privileges: `sudo -H apt-get -y install libhidapi-dev'
[sudo] password di alberto: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libhidapi-hidraw0 libhidapi-libusb0
I seguenti pacchetti NUOVI saranno installati:
  libhidapi-dev libhidapi-hidraw0 libhidapi-libusb0
0 aggiornati, 3 installati, 0 da rimuovere e 11 non aggiornati.
È necessario scaricare 47,8 kB di archivi.
Dopo quest'operazione, verranno occupati 197 kB di spazio su disco.
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu focal/universe amd64 libhidapi-libusb0 amd64 0.9.0+dfsg-1 [14,5 kB]
Scaricamento di:2 http://it.archive.ubuntu.com/ubuntu focal/universe amd64 libhidapi-hidraw0 amd64 0.9.0+dfsg-1 [10,7 kB]
Scaricamento di:3 http://it.archive.ubuntu.com/ubuntu focal/universe amd64 libhidapi-dev amd64 0.9.0+dfsg-1 [22,6 kB]
Recuperati 47,8 kB in 0s (199 kB/s)   
Selezionato il pacchetto libhidapi-libusb0:amd64 non precedentemente selezionato.
(Lettura del database... 228510 file e directory attualmente installati.)
Preparativi per estrarre .../libhidapi-libusb0_0.9.0+dfsg-1_amd64.deb...
Estrazione di libhidapi-libusb0:amd64 (0.9.0+dfsg-1)...
Selezionato il pacchetto libhidapi-hidraw0:amd64 non precedentemente selezionato.
Preparativi per estrarre .../libhidapi-hidraw0_0.9.0+dfsg-1_amd64.deb...
Estrazione di libhidapi-hidraw0:amd64 (0.9.0+dfsg-1)...
Selezionato il pacchetto libhidapi-dev:amd64 non precedentemente selezionato.
Preparativi per estrarre .../libhidapi-dev_0.9.0+dfsg-1_amd64.deb...
Estrazione di libhidapi-dev:amd64 (0.9.0+dfsg-1)...
Configurazione di libhidapi-hidraw0:amd64 (0.9.0+dfsg-1)...
Configurazione di libhidapi-libusb0:amd64 (0.9.0+dfsg-1)...
Configurazione di libhidapi-dev:amd64 (0.9.0+dfsg-1)...
Elaborazione dei trigger per libc-bin (2.31-0ubuntu9.2)...
Install tree:
|
\- gr-osmosdr
   |
   +- airspy
   |
   +- airspyhf
   |
   +- osmo-sdr
   |
   +- rtl-sdr
   |
   +- bladeRF
   |
   +- soapysdr
   |
   +- gr-iqbal
   |  |
   |  \- libosmo-dsp
   |
   +- gr-fcdproplus
   |
   \- hackrf
[INFO] Phase 1 complete: All binary dependencies installed.
[INFO] Phase 2: Recursively installing source packages to prefix:
[INFO] Installing package: hackrf
warning: nessun commit in comune
remote: Enumerating objects: 31, done.
remote: Counting objects: 100% (31/31), done.
remote: Compressing objects: 100% (29/29), done.
remote: Total 14906 (delta 10), reused 16 (delta 2), pack-reused 14875
Ricezione degli oggetti: 100% (14906/14906), 35.98 MiB | 2.53 MiB/s, fatto.
Risoluzione dei delta: 100% (10859/10859), fatto.
Da https://github.com/mossmann/hackrf
 * [nuovo branch]          OTP_USB_IDs -> hackrf/OTP_USB_IDs
 * [nuovo branch]          grf6011     -> hackrf/grf6011
 * [nuovo branch]          h1r5        -> hackrf/h1r5
 * [nuovo branch]          h1r6        -> hackrf/h1r6
 * [nuovo branch]          h1r7        -> hackrf/h1r7
 * [nuovo branch]          master      -> hackrf/master
 * [nuovo branch]          pre-release -> hackrf/pre-release
 * [nuovo branch]          stdout      -> hackrf/stdout
 * [nuovo branch]          transceiver -> hackrf/transceiver
 * [nuovo tag]             2013.06.1           -> 2013.06.1
 * [nuovo tag]             cft-milestone-1     -> cft-milestone-1
 * [nuovo tag]             jawbreaker-20120914 -> jawbreaker-20120914
 * [nuovo tag]             jawbreaker-20121016 -> jawbreaker-20121016
 * [nuovo tag]             v2013.07.1          -> v2013.07.1
 * [nuovo tag]             v2014.04.1          -> v2014.04.1
 * [nuovo tag]             v2014.08.1          -> v2014.08.1
 * [nuovo tag]             v2015.07.1          -> v2015.07.1
 * [nuovo tag]             v2015.07.2          -> v2015.07.2
 * [nuovo tag]             v2017.02.1          -> v2017.02.1
 * [nuovo tag]             v2018.01.1          -> v2018.01.1
 * [nuovo tag]             v2021.03.1          -> v2021.03.1
Clone in 'hackrf' in corso...
Configuring: (100%) [=========================================================]
Building:    (100%) [=========================================================]
Installing:  (100%) [=========================================================]
[INFO] Installation successful.
[INFO] Installing package: gr-fcdproplus
warning: nessun commit in comune
remote: Enumerating objects: 5, done.
remote: Counting objects: 100% (5/5), done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 515 (delta 0), reused 5 (delta 0), pack-reused 510
Ricezione degli oggetti: 100% (515/515), 244.33 KiB | 919.00 KiB/s, fatto.
Risoluzione dei delta: 100% (287/287), fatto.
Da https://github.com/dl1ksv/gr-fcdproplus
 * [nuovo branch]          3.6         -> gr-fcdproplus/3.6
 * [nuovo branch]          gnuradio3.7 -> gr-fcdproplus/gnuradio3.7
 * [nuovo branch]          gnuradio3.8 -> gr-fcdproplus/gnuradio3.8
 * [nuovo branch]          hid-usb     -> gr-fcdproplus/hid-usb
 * [nuovo branch]          master      -> gr-fcdproplus/master
 * [nuovo tag]             fcdproplus-0.1.0 -> fcdproplus-0.1.0
 * [nuovo tag]             v3.6             -> v3.6
 * [nuovo tag]             v3.7             -> v3.7
 * [nuovo tag]             v3.7.12          -> v3.7.12
 * [nuovo tag]             v3.7.2-rc1       -> v3.7.2-rc1
 * [nuovo tag]             v3.7_hidraw      -> v3.7_hidraw
 * [nuovo tag]             with_hidapi      -> with_hidapi
Clone in 'gr-fcdproplus' in corso...
Configuring: (100%) [=========================================================]
Building:    (100%) [=========================================================]
Installing:  (100%) [=========================================================]
[INFO] Installation successful.
[INFO] Installing package: libosmo-dsp
Da https://git.osmocom.org/libosmo-dsp
 * [nuovo branch]          master     -> libosmo-dsp/master
 * [nuovo tag]             0.4.0      -> 0.4.0
 * [nuovo tag]             0.3.0      -> 0.3.0
Clone in 'libosmo-dsp' in corso...
Configuring: (100%) [=========================================================]
Building:    (100%) [=========================================================]
Installing:  (100%) [=========================================================]
[INFO] Installation successful.
[INFO] Installing package: gr-iqbal
Da https://git.osmocom.org/gr-iqbal
 * [nuovo branch]          gr3.6      -> gr-iqbal/gr3.6
 * [nuovo branch]          gr3.7      -> gr-iqbal/gr3.7
 * [nuovo branch]          gr3.8      -> gr-iqbal/gr3.8
 * [nuovo branch]          master     -> gr-iqbal/master
 * [nuovo tag]             v0.37.3    -> v0.37.3
 * [nuovo tag]             v0.38.2    -> v0.38.2
 * [nuovo tag]             v0.36.0    -> v0.36.0
 * [nuovo tag]             v0.37.0    -> v0.37.0
 * [nuovo tag]             v0.37.1    -> v0.37.1
 * [nuovo tag]             v0.37.2    -> v0.37.2
 * [nuovo tag]             v0.38.0    -> v0.38.0
 * [nuovo tag]             v0.38.1    -> v0.38.1
Clone in 'gr-iqbal' in corso...
Configuring: (100%) [=========================================================]
[WARNING] Configuration failed. Re-trying with higher verbosity.
CMake Error at CMakeLists.txt:32 (find_package):
  Could not find a configuration file for package "Gnuradio" that is
  compatible with requested version "3.9".

  The following configuration files were considered but not accepted:

    /home/alberto/prefix-3.8/lib/cmake/gnuradio/GnuradioConfig.cmake, version: 3.8.3.git



-- Configuring incomplete, errors occurred!
See also "/home/alberto/prefix-3.8/src/gr-iqbal/build/CMakeFiles/CMakeOutput.log".
[ERROR] Configuration failed after running at least twice.
[ERROR] Problem occurred while building package gr-iqbal:
Configuration failed
[ERROR] Error installing package gr-iqbal. Aborting.
alberto at alberto-Studio-XPS-1340:~$






-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20210409/fd1b982b/attachment.htm>


More information about the osmocom-sdr mailing list