i can't builld the gr-osmosdr

barry allen savitaristic at gmail.com
Fri Jan 24 03:15:40 UTC 2020


Thanks for your reply .
This helped a lot and i solved the problem😄

On Fri 24 Jan, 2020, 8:42 AM Kyeong Su Shin, <ksshin at postech.ac.kr> wrote:

> Hello Barry:
>
> Your previous e-mails suggest that you installed GNU Radio by using the
> apt command. Are you using the official Ubuntu respository (which is GNU
> Radio 3.7)? Or, are you using some kind third-party packages (maybe 3.8)?
>
> If you are using the official Ubuntu packages (for GNU Radio), then you
> can just install gr-osmosdr from there too (sudo apt install gr-osmosdr).
> If you still want to build gr-osmosdr (if you need to install a modified or
> an updated version of gr-osmosdr), then get gr-osmosdr for GNU Radio 3.7 (I
> think you are using one for the GNU Radio 3.6, which is too old), and
> install missing dependencies as mentioned in the error message (like
> doxygen, libhackrf-dev, etc).
>
> If you absolutely need to run gr-osmosdr for GNU Radio 3.6 (don't do this
> unless you need to run a heavily modified version of gr-osmosdr that only
> supports gr3.6), then you will need to install GNU Radio 3.6, which would
> be pretty annoying on modern Linux distros.
>
> If you did not use the official Ubuntu repo to install GNU Radio and used
> a third-party repo instead, then check if they have their own versions of
> gr-osmosdr. If they don't, install gnuradio-dev (from their repo) and try
> building gr-osmosdr for that. If it's GNU Radio v3.8 or higher, then you
> need to get a version of gr-osmosdr that supports gr 3.8. Again, you will
> need to install some additional dependencies as mentioned in the message.
>
> Regards,
> Kyeong Su Shin
> ------------------------------
> *보낸 사람:* barry allen <savitaristic at gmail.com> 대신 osmocom-sdr <
> osmocom-sdr-bounces at lists.osmocom.org>
> *보낸 날짜:* 2020년 1월 21일 화요일 오후 6:04
> *받는 사람:* osmocom-sdr at lists.osmocom.org <osmocom-sdr at lists.osmocom.org>
> *제목:* i can't builld the gr-osmosdr
>
>
> I can not compile the block gr-osmosdr, obtained block of errors ,if you
> can help me solve the problem ,please.Sincerely thebugslayers
>
> The following are the errors
>
> -- The CXX compiler identification is GNU 7.4.0
> -- The C compiler identification is GNU 7.4.0
> -- Check for working CXX compiler: /usr/bin/c++
> -- Check for working CXX compiler: /usr/bin/c++ -- works
> -- Detecting CXX compiler ABI info
> -- Detecting CXX compiler ABI info - done
> -- Detecting CXX compile features
> -- Detecting CXX compile features - done
> -- Check for working C compiler: /usr/bin/cc
> -- Check for working C compiler: /usr/bin/cc -- works
> -- Detecting C compiler ABI info
> -- Detecting C compiler ABI info - done
> -- Detecting C compile features
> -- Detecting C compile features - done
> -- Build type not specified: defaulting to release.
> -- Found Git: /usr/bin/git (found version "2.17.1")
> -- Extracting version information from git describe...
> -- Configuring Boost C++ Libraries...
> -- Looking for pthread.h
> -- Looking for pthread.h - found
> -- Looking for pthread_create
> -- Looking for pthread_create - not found
> -- Looking for pthread_create in pthreads
> -- Looking for pthread_create in pthreads - not found
> -- Looking for pthread_create in pthread
> -- Looking for pthread_create in pthread - found
> -- Found Threads: TRUE
> -- Boost version: 1.65.1
> -- Found the following Boost libraries:
> -- thread
> -- system
> -- chrono
> -- date_time
> -- atomic
> -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
> -- Checking for module 'gruel'
> -- No package 'gruel' found
> -- Could NOT find GRUEL (missing: GRUEL_LIBRARIES GRUEL_INCLUDE_DIRS)
> -- Checking for module 'gnuradio-core'
> -- No package 'gnuradio-core' found
> -- Could NOT find GNURADIO_CORE (missing: GNURADIO_CORE_LIBRARIES
> GNURADIO_CORE_INCLUDE_DIRS)
> -- Checking for module 'gnuradio-iqbalance'
> -- Found gnuradio-iqbalance, version 0
> -- Could NOT find GNURADIO_IQBALANCE (missing:
> GNURADIO_IQBALANCE_INCLUDE_DIRS)
> -- Checking for module 'uhd'
> -- No package 'uhd' found
> -- Could NOT find UHD (missing: UHD_LIBRARIES UHD_INCLUDE_DIRS)
> -- Checking for module 'gnuradio-uhd'
> -- Found gnuradio-uhd, version 3.9.0
> -- gnuradio-uhd not found.
> -- Could NOT find GNURADIO_UHD (missing: GNURADIO_UHD_INCLUDE_DIRS)
> -- Checking for module 'gnuradio-fcd'
> -- No package 'gnuradio-fcd' found
> -- gnuradio-fcd not found.
> -- Could NOT find GNURADIO_FCD (missing: GNURADIO_FCD_LIBRARIES
> GNURADIO_FCD_INCLUDE_DIRS)
> -- Checking for module 'gnuradio-fcdproplus'
> -- Found gnuradio-fcdproplus, version 3.7.11
> -- Found gnuradio-fcdproplus: /usr/include,
> /usr/lib/x86_64-linux-gnu/libgnuradio-fcdproplus.so
> -- Found GNURADIO_FCDPP:
> /usr/lib/x86_64-linux-gnu/libgnuradio-fcdproplus.so
> -- Checking for module 'libosmosdr'
> -- No package 'libosmosdr' found
> -- libosmosdr not found.
> -- Checking for module 'librtlsdr'
> -- No package 'librtlsdr' found
> -- librtlsdr not found.
> -- Checking for module 'libmirisdr'
> -- No package 'libmirisdr' found
> -- libmirisdr not found.
> -- Checking for module 'libhackrf'
> -- Found libhackrf, version 0.5
> -- Found LIBHACKRF: /usr/local/lib/libhackrf.so
> -- Checking for module 'libairspy'
> -- No package 'libairspy' found
> -- Could NOT find LIBAIRSPY (missing: LIBAIRSPY_LIBRARIES
> LIBAIRSPY_INCLUDE_DIRS)
> -- Checking for module 'libbladeRF'
> -- No package 'libbladeRF' found
> -- libbladeRF not found.
> -- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
> CMake Error at CMakeLists.txt:166 (message):
> Gruel required to build gr-osmosdr
>
> -- Configuring incomplete, errors occurred!
> See also "/home/shan/gr-osmosdr/build/CMakeFiles/CMakeOutput.log".
> See also "/home/shan/gr-osmosdr/build/CMakeFiles/CMakeError.log".
>
> Thanks:)
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20200124/d77dde2b/attachment-0001.htm>


More information about the osmocom-sdr mailing list