gr3.7-qt5 --> CL Error: Unable to queue clear of spectrum buffer

Sipos Csaba dchardware at gmail.com
Wed Dec 25 15:19:02 UTC 2019


Some extra info:

It seems for this old card (9400M), Nvidia recommends driver 340 on their
PPA.

Of course, ubuntu recommends the wrong (390) version to be installed, and
there is no alarm or anything during the process...

Anyway, I think this is it: might need to switch to a newer card...

XTRX with gr-fosphor also works, just needed to add an extra ARG to the
command line:

osmocom_fft -a xtrx -A RXW -s 4000000 -f 804000000 -F

Thanks again for the help!

Regards,
Csaba

Sipos Csaba <dchardware at gmail.com> ezt írta (időpont: 2019. dec. 23., H,
13:07):

> Hi Sylvain,
>
> I reverted to the version 340 nvidia (proprietary) driver, and now it
> works with the "gr3.7-qt5" branch and an rtl-sdr radio. I did not needed to
> revert anything on the gr-fosphor side.
>
> However with the XTRX it outputs nothing (starts up properly, no error
> messages whatsoever, device initialization seems to be fine).
>
> I attached the clinfo output of the working nvidia driver, you might be
> able to find something in it. The XTRX side of thing is likely something
> irrelevant to gr-fosphor, as they still not merged XTRX support to
> gr-osmosdr, I need to use their fairly old gr-osmosdr fork from 2017. The
> only question is where can I get a hold of them, as I was ot able to find a
> public forum, or mail list or anything in regards of XTRX...
>
> Non the less, thanks for the help, and if you find something driver-wise
> on the Nvidia/OpenCL side and want me to test something, I am happy to do
> it.
>
> Regards,
> Csaba
>
> Sylvain Munaut <tnt at 246tnt.com> ezt írta (időpont: 2019. dec. 21., Szo,
> 22:52):
>
>> Hi,
>>
>> > I attached the clinfo output about the version and capabilities of my
>> hardware. Other than this, I am using the proprietary nvidia driver for
>> linux (version 390) with kernel 4.15.0-62-generic, and gnuradio
>> 3.7.13.5~gnuradio~bionic-4.
>>
>> Sure but you said you used fosphor previously on that machine. My
>> question was about the versions you were using back then, not the ones
>> you are running now.
>>
>>
>> > I tried to find that commit you are referring to, but it seems it is no
>> in the git log (or at least I cannot find it). Can you take a look if it is
>> correct?
>>
>> Err sorry it's 306f197108d1a264bebea9f96ac22fa084d402fb
>>
>> Cheers,
>>
>>    Sylvain
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20191225/883fac5e/attachment.html>


More information about the osmocom-sdr mailing list