fl2k on Odroid C1 & Odroid-XU

Ioannis Makris makrisj at gmail.com
Sat Dec 29 05:07:04 UTC 2018


Hello and thanks for the amazing piece of software.
Despite having managed to do much stuff with it under x64 linux, I failed
miserably to make it work under ARM architecture.
To be more specific, I tried the Odroid-XU usb3.0 capable board and the
Odroid-C1 Usb2.0 board to no avail.
Odroid XU kernel: 3.4.y Odroid-C1 kernel: 3.10.107

I used all reasonable ranges of sampling rates and here are the results:
Program seems to run normally. No error codes and.. no buffer underruns at
all. In my i3 laptop I get some buffer underruns but to arm I have never
spotted such a message no matter what the sampling rate is.

When the sampling rate is a fraction of what fl2k_test reports as maximum,
I see the sampling rate spike on my spectrum analyzer (Advantest TR4132).
But when I opt for fl2k_fm, I see no response whatsoever other than the
enabling of the DAC visible as an increase of a few dB's of noise and a
hint (3dB C/N)  at the sampling frequency.

I tried the binary repositories of libusb for my distribution, and I even
compiled locally libusb from source - nothing changed.

What could be making such a mess? I have spent over 3 days on efforts to no
avail. I just want to explore upconversion possibilities but I need to
encapsulate both the host and the FL2000 into a shield in order to get
meaningful experimental results.

Please help if you can
Thanks
Ioannis (John) Makris
SV9OFO
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20181229/827748f3/attachment.html>


More information about the osmocom-sdr mailing list