anyone have make fail on build.make:54: recipe for target 'src/CMakeFiles/rtl_tcp.dir/rtl_tcp.c.o'??

loren butler vo1pwf at
Mon Mar 16 19:29:42 UTC 2015

make produces the following...i have tried the main and mirror to see if
there was a difference....
running raspian, the same instructions worked before...however im stuck in
my tracks with this one

Scanning dependencies of target convenience_static
[ 5%] Building C object
Linking C static library libconvenience_static.a
[ 5%] Built target convenience_static
Scanning dependencies of target rtlsdr_shared
[ 10%] Building C object src/CMakeFiles/rtlsdr_shared.dir/librtlsdr.c.o
[ 15%] Building C object src/CMakeFiles/rtlsdr_shared.dir/tuner_e4k.c.o
[ 20%] Building C object src/CMakeFiles/rtlsdr_shared.dir/tuner_fc0012.c.o
[ 25%] Building C object src/CMakeFiles/rtlsdr_shared.dir/tuner_fc0013.c.o
[ 30%] Building C object src/CMakeFiles/rtlsdr_shared.dir/tuner_fc2580.c.o
[ 35%] Building C object src/CMakeFiles/rtlsdr_shared.dir/tuner_r82xx.c.o
Linking C shared library
[ 35%] Built target rtlsdr_shared
Scanning dependencies of target rtl_adsb
[ 40%] Building C object src/CMakeFiles/rtl_adsb.dir/rtl_adsb.c.o
Linking C executable rtl_adsb
[ 40%] Built target rtl_adsb
Scanning dependencies of target rtl_eeprom
[ 45%] Building C object src/CMakeFiles/rtl_eeprom.dir/rtl_eeprom.c.o
Linking C executable rtl_eeprom
[ 45%] Built target rtl_eeprom
Scanning dependencies of target rtl_fm
[ 50%] Building C object src/CMakeFiles/rtl_fm.dir/rtl_fm.c.o
Linking C executable rtl_fm
[ 50%] Built target rtl_fm
Scanning dependencies of target rtl_power
[ 55%] Building C object src/CMakeFiles/rtl_power.dir/rtl_power.c.o
Linking C executable rtl_power
[ 55%] Built target rtl_power
Scanning dependencies of target rtl_sdr
[ 60%] Building C object src/CMakeFiles/rtl_sdr.dir/rtl_sdr.c.o
Linking C executable rtl_sdr
[ 60%] Built target rtl_sdr
Scanning dependencies of target rtl_tcp
[ 65%] Building C object src/CMakeFiles/rtl_tcp.dir/rtl_tcp.c.o
/home/davinci/librtlsdr/src/rtl_tcp.c:28:23: fatal error: arpa/inet.h: No
such file or directory
compilation terminated.
src/CMakeFiles/rtl_tcp.dir/build.make:54: recipe for target
'src/CMakeFiles/rtl_tcp.dir/rtl_tcp.c.o' failed
make[2]: *** [src/CMakeFiles/rtl_tcp.dir/rtl_tcp.c.o] Error 1
CMakeFiles/Makefile2:355: recipe for target
'src/CMakeFiles/rtl_tcp.dir/all' failed
make[1]: *** [src/CMakeFiles/rtl_tcp.dir/all] Error 2
Makefile:113: recipe for target 'all' failed
make: *** [all] Error 2
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the osmocom-sdr mailing list