Build problem after updating boost

Calum caluml at gmail.com
Wed Aug 19 14:55:23 UTC 2015


Just noticed that the update yesterday took me from CentOS 6.6 to 6.7, so
more than just boost was updated.
However, it still seems like a strange file it's searching for - I can't
find any reference to it anywhere.

On 19 August 2015 at 15:24, Calum <caluml at gmail.com> wrote:

> Hello all,
>
> I had a problem building gr-osmosdr a few days ago (it was looking in
> /usr/lib64/lib64), which I worked around by symlinking a couple of files to
> where they were being looked for.
>
> However, since an update of boost yesterday, I now get an error
> complaining about a boost file I don't have on my system.
> "/usr/lib64/lib64/libboost_date_time-d.a"
>
> Any ideas what's going wrong here?
> Centos 6.6
> Previous boost version: 1.41.0-25
> New boost version: 1.41.0-27
>
> $ git clone git://git.osmocom.org/gr-osmosdr
> Initialized empty Git repository in /home/calum/src/gr-osmosdr/.git/
> remote: Counting objects: 3818, done.
> remote: Compressing objects: 100% (2510/2510), done.
> remote: Total 3818 (delta 2736), reused 1888 (delta 1270)
> Receiving objects: 100% (3818/3818), 926.14 KiB | 1.13 MiB/s, done.
> Resolving deltas: 100% (2736/2736), done.
> $ cd gr-osmosdr
> $ mkdir build ; cd build
> $ cmake ..
> -- The CXX compiler identification is GNU 4.4.7
> -- The C compiler identification is GNU 4.4.7
> -- Check for working CXX compiler: /usr/bin/c++
> -- Check for working CXX compiler: /usr/bin/c++ -- works
> -- Detecting CXX compiler ABI info
> -- Detecting CXX compiler ABI info - done
> -- Check for working C compiler: /usr/bin/cc
> -- Check for working C compiler: /usr/bin/cc -- works
> -- Detecting C compiler ABI info
> -- Detecting C compiler ABI info - done
> -- Build type not specified: defaulting to release.
> -- Found Git: /usr/bin/git (found version "1.7.1")
> -- Extracting version information from git describe...
> -- Configuring Boost C++ Libraries...
> CMake Error at /usr/lib64/boost/Boost.cmake:536 (message):
>   The imported target "boost_date_time-static-debug" references the file
>
>      "/usr/lib64/lib64/libboost_date_time-d.a"
>
>   but this file does not exist.  Possible reasons include:
>
>   * The file was deleted, renamed, or moved to another location.
>
>   * An install or uninstall procedure did not complete successfully.
>
>   * The installation package was faulty and contained
>
>      "/usr/lib64/boost/Boost.cmake"
>
>   but not all the files it references.
>
> Call Stack (most recent call first):
>   /usr/lib64/boost/BoostConfig.cmake:28 (include)
>   /usr/share/cmake/Modules/FindBoost.cmake:177 (find_package)
>   CMakeLists.txt:122 (find_package)
>
>
> -- Configuring incomplete, errors occurred!
> See also "/home/calum/src/gr-osmosdr/build/CMakeFiles/CMakeOutput.log".
> $
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20150819/0e1a0fe1/attachment.html>


More information about the osmocom-sdr mailing list