Still problem with "cb transfer status 1, cancelling" -> segmentation fault, libusb

Markus Gonser m48 at mksg.de
Sun Feb 17 13:17:06 UTC 2013


Hello Peter,

thank you for your answer! I had time to try out your suggestion today: i.e. revert the change from commit 3cbf1392612a0c6f02ec178f8e78568138f12b0a
which you described in 
http://lists.osmocom.org/pipermail/osmocom-sdr/2013-January/000440.html

It works now without problems! So what do we do? For me the problem is solved, but for others not. I don't know libusb well, what would have to be done, to make implement it properly? 

Markus


Am 12.02.2013 um 22:33 schrieb Peter A. Bigot

> On 02/12/2013 01:34 PM, Markus Gonser wrote:
>> Hello,
>> 
>> I am new to this mailing list, but that does not mean that I have been following SDR activities here at osmocom and especially gnuradio actively. I am not a linux professional, but "intermediate beginner". I currently have a problem running my Hama Nano DVB-T Dongle which I cannot solve and therefore need to turn to you with the following problem:
>> 
>> I hava an Intel Pentium 977 machine running Ubuntu 12.04LTS in the 64bit version. I compiled and installed gnuradio using the script from Marcus Leech (http://www.sbrac.org/files/build-gnuradio)
>> 
>> I have an Hama Nano DVB-T Dongle which contains an RTL2832U Chip combined with the E4000 frontend.
>> 
>> When I try to access the Dongle via rtlsdr (either via sample programs in GRC or simply via rtl_test -s) I get
>> 
>> cb transfer status: 1, canceling...
>> 
>> Library error 0, exiting...
>> Speicherzugriffsfehler (Speicherabzug geschrieben) (engl.: "segmentation fault")
>> 
>> I found two threads regarding this problem in this mailinglist:
>> 1) http://lists.osmocom.org/pipermail/osmocom-sdr/2013-January/000443.html
>> 2) http://lists.gnumonks.org/pipermail/osmocom-sdr/2012-August/000201.html
>> 
>> With respect to the former (1) I checked my version of libusb-1.0-0-dev which is 2:1.0.9~rc3-2ubuntu1
>> With respect to the latter (2) (and older post) I checked in my source of the rtlsdr library if the proposed change is included and it is.
>> 
>> So I do not have any clue how and where to proceed further. I'd be happy to give you any more information you need and try out patches. If you have any ideas or could point me to the right direction, I'd be very happy about
>> 
>> Thanks upfront for your consideration and best regards,
>> 
>> Markus
>> 
>> P.S.: The dongle worked on this machine before, but I do not remember if I had the 32bit Ubuntu version running and which versions of gnuradio, etc. were installed.
> My conclusion from thread (1), based on the response from Peter Stuge, was that rtl-sdr was mis-using libusb by closing the device without waiting for it to finish, and it's not a fault in libusb.  Looks like git://git.osmocom.org/osmo-sdr is down, and the cgit browser is out of date, so I can't tell what's been done since.  But the fix needs to be made in rtl-sdr, whether it's reverting the patch as I suggested or correcting it to wait before shutting things down.
> 
> Peter

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/osmocom-sdr/attachments/20130217/d6a54a0a/attachment.html>


More information about the osmocom-sdr mailing list