osmo-trx.git branch master updated. 38b69871ae87506c21a6b53ba418139d24305590

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/osmocom-commitlog@lists.osmocom.org/.

gitosis at osmocom.org gitosis at osmocom.org
Wed Mar 22 18:33:27 UTC 2017


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "OpenBTS' transceiver retro-fit".

The branch, master has been updated
       via  38b69871ae87506c21a6b53ba418139d24305590 (commit)
       via  7db522b6d951413d7d62f9c7e52a9b2100622399 (commit)
       via  ae09b04e26068182b870d7e136e25eeb3767396a (commit)
       via  b61c610cd964107aea2ccdf261575237d07ea994 (commit)
       via  132fb247b101292818afaf72f7508b594625cc25 (commit)
       via  1c0b8b355ccbb31048973e838933d0e29039ad32 (commit)
       via  1dd05cf35a8c5e3c2acfbc4e23e26d41ea4a9aa9 (commit)
      from  14d13b67dcd4fa35b03cbbef0c5ddd2622b89155 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
http://cgit.osmocom.org/osmo-trx/commit/?id=38b69871ae87506c21a6b53ba418139d24305590

commit 38b69871ae87506c21a6b53ba418139d24305590
Author: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Date:   Fri Mar 17 18:20:09 2017 -0700

    BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
    
    This makes code simpler and will allow us send -127..127 soft bits towards
    osmo-bts instead of 0..255 bits.
    
    Change-Id: I16ecc3d4c829dcf0f619ad995bc9d4a4ed8af0a4

http://cgit.osmocom.org/osmo-trx/commit/?id=7db522b6d951413d7d62f9c7e52a9b2100622399

commit 7db522b6d951413d7d62f9c7e52a9b2100622399
Author: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Date:   Fri Mar 17 18:00:50 2017 -0700

    BitVector: Remove convolutional codec - we don't use it in osmo-trx.
    
    Now we have more fexibility in how we represent SoftVector, since we
    no longer depend on the particular convolutional codec implementation.
    
    Change-Id: I3006b6a26c5eff59dbe9c034f689961802f1d0d0

http://cgit.osmocom.org/osmo-trx/commit/?id=ae09b04e26068182b870d7e136e25eeb3767396a

commit ae09b04e26068182b870d7e136e25eeb3767396a
Author: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Date:   Wed Mar 15 21:26:06 2017 +0300

    CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
    
    We use other symbols to show that these bits has less confidence:
    o and . for 0 with less confidence
    | and ' for 1 with less confidence
    
    Change-Id: I747a17568ee48f1f3163e8dfab2e450af85e6435

http://cgit.osmocom.org/osmo-trx/commit/?id=b61c610cd964107aea2ccdf261575237d07ea994

commit b61c610cd964107aea2ccdf261575237d07ea994
Author: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Date:   Fri Mar 17 18:22:19 2017 -0700

    Call vectorSlicer() right before packing bits for transmission to osmo-bts.
    
    vectorSlicer() converts soft-bits from -1..+1 to 0..1 while we want
    to keep SoftVector in -1..+1 mode until the last minute, because at some
    point we'll want to transmit -1..+1 to osmo-bts instead of converting it
    from 0..1 back to -1..+1 on the osmo-bts side.
    
    Plus it removes code duplication - we call it once instead of twice.
    
    Change-Id: Idd6ddd7ac219afb0df055a692632678b66373764

http://cgit.osmocom.org/osmo-trx/commit/?id=132fb247b101292818afaf72f7508b594625cc25

commit 132fb247b101292818afaf72f7508b594625cc25
Author: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Date:   Fri Mar 17 17:22:33 2017 -0700

    sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
    
    This makes it similar to 8-PSK demod and also saves a bit of lines ofcode and
    should give us a tiny improvement in performance.
    
    Ideally we need to remove vector slicing at all, because in osmo-bts-trx
    we convert back to +-1.0 again (actually to +-127, but it doesn't mater).
    So we should rather transmit +-1.0 values to avoid double conversion.
    
    Change-Id: If9ed6f0f80fbe88c994b2f9c3cae91d0d57f4442

http://cgit.osmocom.org/osmo-trx/commit/?id=1c0b8b355ccbb31048973e838933d0e29039ad32

commit 1c0b8b355ccbb31048973e838933d0e29039ad32
Author: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Date:   Fri Mar 17 16:12:47 2017 -0700

    sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
    
    Change-Id: Ibcef8d7d4a2c06865bed7e4091ccc8dbbd494d77

http://cgit.osmocom.org/osmo-trx/commit/?id=1dd05cf35a8c5e3c2acfbc4e23e26d41ea4a9aa9

commit 1dd05cf35a8c5e3c2acfbc4e23e26d41ea4a9aa9
Author: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Date:   Wed Mar 15 23:23:36 2017 +0300

    sigProcLib: make energyDetect() simpler by returning actual energy.
    
    Change-Id: I9bf97f2dc03fea9bebcf43198dfb05f6e4694e9c

-----------------------------------------------------------------------

Summary of changes:
 CommonLibs/BitVector.cpp       | 257 ++---------------------------------------
 CommonLibs/BitVector.h         | 149 +-----------------------
 CommonLibs/BitVectorTest.cpp   |  28 -----
 Transceiver52M/Transceiver.cpp |   9 +-
 Transceiver52M/sigProcLib.cpp  |  53 ++++-----
 Transceiver52M/sigProcLib.h    |  26 ++---
 6 files changed, 52 insertions(+), 470 deletions(-)


hooks/post-receive
-- 
OpenBTS' transceiver retro-fit



More information about the osmocom-commitlog mailing list