openbsc.git branch neels/sgsn-id-pretty updated. 0.14.0-193-ga16feb7

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/osmocom-commitlog@lists.osmocom.org/.

gitosis at osmocom.org gitosis at osmocom.org
Wed Sep 23 21:29:05 UTC 2015


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "The OpenBSC GSM Base Station Controller (+MSC/HLR/SGSN)".

The branch, neels/sgsn-id-pretty has been updated
  discards  dd407d8cd675ae05fd4a1c5375716d3efe38776e (commit)
  discards  993bf2adb79d2a7853c2e99ff34fb7b330930871 (commit)
       via  a16feb74a7c09919739015e989433cad1abe8064 (commit)
       via  438633a2d52e9f88b1571eebf0578bcc4ac39279 (commit)
       via  9b436c30b2d4c8ea9a703621486e6ad41bd4d5a9 (commit)

This update added new revisions after undoing existing revisions.  That is
to say, the old revision is not a strict subset of the new revision.  This
situation occurs when you --force push a change and generate a repository
containing something like this:

 * -- * -- B -- O -- O -- O (dd407d8cd675ae05fd4a1c5375716d3efe38776e)
            \
             N -- N -- N (a16feb74a7c09919739015e989433cad1abe8064)

When this happens we assume that you've already had alert emails for all
of the O revisions, and so we here report only the revisions in the N
branch from the common base, B.

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
http://cgit.osmocom.org/openbsc/commit/?id=a16feb74a7c09919739015e989433cad1abe8064

commit a16feb74a7c09919739015e989433cad1abe8064
Author: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Date:   Wed Sep 23 23:28:36 2015 +0200

    Implement OAP for SGSN registration.
    
    Needs a new ipaccess_proto_ext enum value IPAC_PROTO_EXT_OAP from libosmocore,
    added in libosmocore.git:5eeb17a0178a72d291cb99f2391d8ea7e9b65dd4.
    
    Implement the Osmocom Authentication Protocol, to allow an SGSN to register
    with an IPA peer. The aim is to allow multiple SGSNs talking to a single MAP
    proxy.
    
    Have this API separation:
    - ipa_client_conn provides a bare connection (unchanged).
    - ipa_client provides general IPA connection verification using timeouts and an
      IPA ping/pong.
    - gprs_ipa_client muxes an ipa_client to the GSUP and OAP APIs.
    
    While ipa_client_conn and ipa_client above are very general, gprs_ipa_client is
    a specific use "with real data".
    
    ipa_client has previously been gprs_gsup_client. Remove GSUP specifics, change
    naming and log output to say "IPA" instead. (A previous commit has already
    renamed the gprs_gsup_client files to make this commit easier to read.)
    
    Add gprs_ipa_client to soak up the GSUP specifics from ipa_client (basically
    just the protocol numbers). Also soak up gprs_subscr_init() and gsup_read_cb()
    from gprs_subscriber.c. And, of course, apply the OAP API.
    
    Add gprs_oap_messages.{h,c} and gprs_oap.{h,c} to implement the OAP protocol.
    Add a gprs_oap_state field to (new) gprs_gsup_client.
    
    Add a gprs_oap_config field to sgsn_config.
    Rename sgsn_config.gsup_server_* to ipa_server_*. Apply this in sgsn_vty.c.
    
    Change from gprs_gsup_client to the new gprs_ipa_client API in
    - gprs_subscriber.c
    - sgsn_main.c (gprs_subscr_init() has become gprs_ipa_client_init())
    
    Move some static functions to gprs_utils.h to avoid code duplication, I hope
    the location is a sufficiently good choice:
    - constant_time_cmp() from bsc_nat.c for gprs_oap_evaluate_challenge(), now
      called gprs_constant_time_cmp().
    - encode_big_endian() and decode_big_endian() from gprs_gsup_messages.c for
      gprs_oap_decode() and gprs_oap_encode(), now called gprs_encode_big_endian()
      and gps_decode_big_endian().
    Apply the function renames in the mentioned .c files.
    
    Add OAP unit tests to sgsn_test.c: test_oap() and test_sgsn_registration().
    Update sgsn_test.ok accordingly.
    
    Sponsored-by: On-Waves ehf

http://cgit.osmocom.org/openbsc/commit/?id=438633a2d52e9f88b1571eebf0578bcc4ac39279

commit 438633a2d52e9f88b1571eebf0578bcc4ac39279
Author: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Date:   Wed Sep 23 23:28:34 2015 +0200

    ipa, gsup: file rename to prepare for refactoring
    
    Rename gprs_gsup_client.* to ipa_client.*.
    
    To ease diff reading for the upcoming commit, this commit performs a file
    rename only.
    
    Background: currently, GSUP is the only protocol spoken on the IPA wire. We
    will now add OAP, a new protocol to register the SGSN with a MAP proxy. What
    has been only the GSUP client will mostly become the general IPA client.
    
    Sponsored-by: On-Waves ehf

http://cgit.osmocom.org/openbsc/commit/?id=9b436c30b2d4c8ea9a703621486e6ad41bd4d5a9

commit 9b436c30b2d4c8ea9a703621486e6ad41bd4d5a9
Author: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Date:   Wed Sep 23 23:28:27 2015 +0200

    Add initial OAP protocol design document
    
    Sponsored-by: On-Waves ehf

-----------------------------------------------------------------------

Summary of changes:
 openbsc/include/openbsc/Makefile.am         |   8 +-
 openbsc/include/openbsc/gprs_ipa_client.h   |  53 ++++
 openbsc/include/openbsc/gprs_oap.h          |  65 +++++
 openbsc/include/openbsc/gprs_oap_messages.h |  70 ++++++
 openbsc/include/openbsc/gprs_utils.h        |   5 +
 openbsc/include/openbsc/ipa_client.h        |  43 ++--
 openbsc/include/openbsc/sgsn.h              |  13 +-
 openbsc/src/gprs/Makefile.am                |   6 +-
 openbsc/src/gprs/gprs_gsup_messages.c       |  44 +---
 openbsc/src/gprs/gprs_ipa_client.c          | 159 ++++++++++++
 openbsc/src/gprs/gprs_oap.c                 | 207 ++++++++++++++++
 openbsc/src/gprs/gprs_oap_messages.c        | 179 ++++++++++++++
 openbsc/src/gprs/gprs_subscriber.c          |  43 +---
 openbsc/src/gprs/gprs_utils.c               |  39 +++
 openbsc/src/gprs/ipa_client.c               | 233 +++++++++---------
 openbsc/src/gprs/sgsn_main.c                |   5 +-
 openbsc/src/gprs/sgsn_vty.c                 |  49 ++--
 openbsc/src/osmo-bsc_nat/bsc_nat.c          |  16 +-
 openbsc/tests/sgsn/Makefile.am              |   6 +-
 openbsc/tests/sgsn/sgsn_test.c              | 361 ++++++++++++++++++++++++++--
 openbsc/tests/sgsn/sgsn_test.ok             |   5 +
 21 files changed, 1343 insertions(+), 266 deletions(-)
 create mode 100644 openbsc/include/openbsc/gprs_ipa_client.h
 create mode 100644 openbsc/include/openbsc/gprs_oap.h
 create mode 100644 openbsc/include/openbsc/gprs_oap_messages.h
 create mode 100644 openbsc/src/gprs/gprs_ipa_client.c
 create mode 100644 openbsc/src/gprs/gprs_oap.c
 create mode 100644 openbsc/src/gprs/gprs_oap_messages.c


hooks/post-receive
-- 
The OpenBSC GSM Base Station Controller (+MSC/HLR/SGSN)



More information about the osmocom-commitlog mailing list