[PATCH 1/2] Add convolutional code generators for CS2/3

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/OpenBSC@lists.osmocom.org/.

Sylvain Munaut 246tnt at gmail.com
Wed Apr 20 05:13:16 UTC 2016


Hi,


A few more comments, although those are mainly style so unless someone
else also has those concerns, I'm not opposed to merging.


>  src/gsm/conv_cs2_gen.c        | 211 +++++++++++++++++++++++++++++
>  src/gsm/conv_cs3_gen.c        | 299 ++++++++++++++++++++++++++++++++++++++++++

Why the _gen suffix ?

If they're fully automatically generated, then the build process
should generate them, they should not be in the repo at all.


> +extern const struct osmo_conv_code osmo_conv_gsm0503_cs2;
> +extern const struct osmo_conv_code osmo_conv_gsm0503_cs3;

Looking at all the other symbol in osmogsm, it seems we deemed 'osmo_'
to be redudant and so maybe "gsm0503_conv_cs2" would fit better in the
naming scheme ?


> +static const uint8_t osmo_conv_gsm0503_cs2_output[][2] = {

All those being purely internal symbols, then don't need osmo_conv either


Cheers,

   Sylvain



More information about the OpenBSC mailing list