[op25-dev] Attribute Error: 'file_source_sptr' object has no attribute 'set_gain_adjust'

ikjtel ikj1234i at yahoo.com
Tue Jul 23 13:13:51 UTC 2019


 Hello Teresa
We don't have a huge number of success reports for the TX - so accordingly this is high priority and I'd very much like to get it nailed down.  Looking at the command line, I copy/pasted it into a terminal and some of the single quotes appear to have pasted as strange backtick characters (‘) rather than as single quotes (').  If these characters actually appear in your command (as opposed to being an artifact of copying/pasting) they will cause trouble.  Looking at these characters on-screen they also appear incorrect, but I need a magnifying glass to see them in detail.   Could I have you try fixing this first before we proceed to look at the actual error message.   Noting also that there should be a matching (un)quote following the string "PGA:90" that also appears to be missing lends some additional corroboration to the possibility of a malformed command line....
Max
p.s. I ran the results of the paste thru "od -t x1" and there appear to be several non-ASCII characters (anything greater than or equal to 0x80 is invalid):
0000000 2e 2f 64 76 5f 74 78 2e 70 79 20 2d 70 20 70 32
0000020 35 20 2d 2d 61 72 67 73 20 e2 80 98 75 68 64 e2
0000040 80 99 20 2d 74 20 2e 2f 31 30 31 31 2e 64 61 74
0000060 20 2d 72 20 2d 51 20 34 33 30 31 33 37 35 30 30
0000100 20 2d 71 20 31 20 2d 67 61 69 6e 73 20 e2 80 98
0000120 50 47 41 3a 39 30 20 2d 76 20 33 20 2d 69 20 34
0000140 30 30 30 30 30 0a


    On Monday, July 22, 2019, 6:13:53 PM EDT, Bender, Theresa <tbender at wpi.edu> wrote:  
 
  <!--#yiv1406257489 _filtered #yiv1406257489 {font-family:"Cambria Math";panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv1406257489 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}#yiv1406257489 #yiv1406257489 p.yiv1406257489MsoNormal, #yiv1406257489 li.yiv1406257489MsoNormal, #yiv1406257489 div.yiv1406257489MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:"Calibri", sans-serif;}#yiv1406257489 a:link, #yiv1406257489 span.yiv1406257489MsoHyperlink {color:#0563C1;text-decoration:underline;}#yiv1406257489 a:visited, #yiv1406257489 span.yiv1406257489MsoHyperlinkFollowed {color:#954F72;text-decoration:underline;}#yiv1406257489 span.yiv1406257489EmailStyle17 {font-family:"Calibri", sans-serif;color:windowtext;}#yiv1406257489 .yiv1406257489MsoChpDefault {font-family:"Calibri", sans-serif;} _filtered #yiv1406257489 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv1406257489 div.yiv1406257489WordSection1 {}-->
I’m trying to make a OP25 Transmitter with a B200 mini, as in the video. I’m using the same command line as in the video (./dv_tx.py -p p25 --args ‘uhd’ -t ./1011.dat -r -Q 430137500 -q 1 -gains ‘PGA:90 -v 3 -i 400000). I keep receiving the error “Attribute Error: 'file_source_sptr' object has no attribute 'set_gain_adjust'”.
 
  
 
I’m new to using SDRs and the B200 mini, so I’d appreciate any advice! Thanks!
   
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20190723/7111d065/attachment.html>


More information about the op25-dev mailing list