[op25-dev] Some help with Error in `python' please

'William Becks' wa8wg@centurytel.net [op25-dev] op25-dev at yahoogroups.com
Wed Apr 18 22:05:13 UTC 2018


Dick,

 

The source code for the Wireshark p25 dissector has disappeared from the osmocom.org website and seems to be a dead issue these days.  It really serves no useful role in monitoring p25 trunked systems unless you specifically have a need for in-depth analysis.   There is excellent debugging options available with the proper level of verbose enabled on the rx.py command line that dumps a host of information to the stderr log file.

 

The error message you’re seeing in 14.04 is probably due to the need to create /etc/modprobe.d/dvb-blacklist.conf in support of the RTL-SDR dongle.  When running 16.04 this is an not an issue and is an unnecessary step in  your configuration tasks.  Feel free to PM offline and I will be glad to help you get 16.04 + op25 up and running on VirtualBox.

 

Bill

 

 

 

 

From: op25-dev at yahoogroups.com [mailto:op25-dev at yahoogroups.com] 
Sent: Wednesday, April 18, 2018 4:09 PM
To: op25-dev at yahoogroups.com
Subject: Re: RE: RE: [op25-dev] Some help with Error in `python' please

 

  

Bill

   Well, I installed Ubuntu 14.04, updated it, then used the boatbod version of op25. I compiled it as my userid and as root. they wouldn't start due to a divide by zero exception which I never had using

Ubuntu 16.04. So, will re-install 16 and do the same thing. Once back to at least running I'll perform your sound test and go from there. BTW....is there a valid installation for wireshark as well? Thanks
yet again for your help and time on this.....will let you know what happens....

 

 

On Wednesday, April 18, 2018, 3:38:54 PM CDT, 'William Becks' wa8wg at centurytel.net [op25-dev] <op25-dev at yahoogroups.com> wrote: 

 

 

  

Dick, /etc/modprobe.d/dvb-blacklist.conf



 

There should be no issues moving to Ubuntu 16.04 unless you don’t you’re missing an rx.py command line option or have an incorrect virtual machine audio setting.  Have you tired running speaker-test (speaker-test -t sine -f 400 -c 2) from the terminal?  Alternatively you can click into the system settings on the desktop then select sound where you can use the GUI tool to  configure and test your speakers..

 

It that checks out, then please post your rx.py command line and trunk.tsv files.

 

Bill

 

 

From: op25-dev at yahoogroups.com [mailto:op25-dev at yahoogroups.com] 
Sent: Wednesday, April 18, 2018 12:45 PM
To: op25-dev at yahoogroups.com
Subject: Re: RE: [op25-dev] Some help with Error in `python' please

 

  

Thanks Bill and all for all your help.....i did have it working on ubuntu 14 and by working I was hearing traffic both ways......I have installed ubuntu 16.04 , updated it, loaded the max branch that your referring

to from the boatbod URL...I then su to root and run the install.sh script....it runs but am having no sound again...is your ubuntu the 14 or 16 version? I'll wait on hearing back and go from there.....thanks again
for everyones help too....

 

 

On Wednesday, April 11, 2018, 3:30:05 PM CDT, 'William Becks' wa8wg at centurytel.net [op25-dev] <op25-dev at yahoogroups.com> wrote: 

 

 

  

Dick,

 

I have op25 running on two separate Ubuntu 16.04 Virtual Machines in Oracle VirtualBox.  One of the VM’s has the MAX branch while the other has Graham’s [Boadbod] version.   I believe you are using virtualization and can accomplish this much easier than trying to install both on the same machine and having to keep the two versions from conflicting with each other.   I’ve not installed the Osmocom version in a long time because of the numerous code and feature improvements by Max, Graham, and a few other contributors.

 

Bill

 

 

From: op25-dev at yahoogroups.com [mailto:op25-dev at yahoogroups.com] 
Sent: Wednesday, April 11, 2018 3:08 PM
To: op25-dev at yahoogroups.com
Subject: Re: [op25-dev] Some help with Error in `python' please

 

  

Can you install both versions of op25, ie.. max branch and osmocom op25 version on the same installation

of ubuntu and it work?

 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20180418/504c22e7/attachment.html>


More information about the op25-dev mailing list