[op25-dev] Re: new recipe for building OP25

justeu.badd@gmail.com [op25-dev] op25-dev at yahoogroups.com
Fri Sep 2 18:41:07 UTC 2016


I went through this enough for my Windows based machine, I decided to make a bootable USB Radio installation for my Mac Book Pro. After the "successful" installation I ran the program and, it took off and flew, I changes some command line functions to tune it to my trunk frequency and it gave me an error (no big deal, just change value in trunk.tsv file). I closed out sudo nano, saved the edits and, when I went back to run the command line, "the command did not exist" - did an "ls" , the whole 'gr-op25' folder was gone from the pybomb_legacy directory 

I'm thinking to myself, "Wow, you really screwed that up, how did you do it"? I tried to repair the install but it was late in the evening so, I left it alone - for two days; I reformatted the drive and set it up for OS-X; when I tried to run the program, it was too messed around to work and, I did not feel like de-bugging it so, I started with a brand new 32 GB USB Drive - (I went through the whole procedure for the third time for the MacBook Pro laptop).

ETA: I reserved 9999 MB for "Persistence"

New Thumb-drive, new installation, fresh set of eyes and, I imputed the commands and, it works (as expected), I carefully edited my command line and .TSV files and, it works UNTIL, I power down the laptop and restart in Ubuntu again; I enter my command line and, I get a message that the command didn't exist, BULL****! Again, there was no 'gr-op25' folder in the pybombs_legacy after I had seen it running.

The directory did not exist, in spite of editing the files as directed, these installs had no "PERSISTENCE". The installation and the folders/directories connected with them didn't exist. Documents that I saved in the documents folder were gone. I checked the first USB drive and found the same thing, there was not Persistence, the information was lost when booted up; regardless, saved or installed made no difference.

This only happens with the USB drives setup to boot on OS-X systems, Windows installations have "Persistence" and the information survives over a reboot. 

 Am I not doing something right?
 

 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20160902/bfb5836f/attachment.html>


More information about the op25-dev mailing list