[op25-dev] Re: Wireshark P25 patch

'lists@lazygranch.com' lists@lazygranch.com [op25-dev] op25-dev at yahoogroups.com
Thu Jun 30 01:23:59 UTC 2016


On 29 Jun 2016 05:37:38 -0700
"ikj1234i at yahoo.com [op25-dev]" <op25-dev at yahoogroups.com> wrote:

> could you please post the full output of the failed compile attempt -
> no guarantees but it might be a simple fix / omission. 

Well this post got my attention. I tried to load op25 some time ago,
had problems, grumbled, and went onto other projects. But running
wireshark on P25 sounds interesting.

That said, I downloaded the wireshark source. (Might as well see if I
can modify wireshark first before tackling OP25 again.) The current
wireshark source is 2.0.4. The patches are for 1.8.5. 

That said, I figured I would see how far I can get. No problem with the
source and tar. I build in /usr/local/src. 

I see wireshark has a plugins directory, so I cd'd into it. (I don't
like putting multiple commands on one line.)

Once in the plugin directory, I did:
svn checkout http://op25.osmocom.org/svn/trunk/wireshark/plugins/p25 p25
Output is:
------------------------------------
A    p25/Makefile.common
A    p25/AUTHORS
A    p25/plugin.rc.in
A    p25/Makefile.nmake
A    p25/moduleinfo.h
A    p25/COPYING
A    p25/Makefile.am
A    p25/packet-p25cai.c
A    p25/moduleinfo.nmake
A    p25/README
Checked out revision 328.
------------------------------------

Now the next step is to apply the patches. The text on the instruction
page indicates this is done outside of the plugin directory. There is
no explicit instruction, but I did a cd .. to go up one level. I assume
that is what outside the plugin directory means.

svn checkout http://op25.osmocom.org/svn/trunk/wireshark/patches
yields:
---------------------------------
A    patches/wireshark-1.4.3.patch
A    patches/wireshark-1.2.6.patch
A    patches/wireshark-1.6.5.patch
A    patches/wireshark-1.8.5.patch
A    patches/wireshark-1.0.2.patch
A    patches/wireshark-1.2.2.patch
Checked out revision 328.
------------------------------------
I assume I need a new patch, but I tried to run the patch command
anyway.

patch -p1 < patches/wireshark-1.8.5.patch
yields:
---------------------------------------------------
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naur a/configure.in b/configure.in
|--- a/configure.in     2013-01-30 04:26:30.000000000 +1000
|+++ b/configure.in     2013-01-31 21:49:06.000000000 +1000
--------------------------
File to patch: ^C
------------------------------------------

You can see I controlled-C out of this.
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20160629/8dbd6151/attachment.html>


More information about the op25-dev mailing list