[op25-dev] gr-fsk4 install Error: Unable to find 'pmt_swig.i'

md123 at nycap.rr.com md123 at nycap.rr.com
Mon Mar 4 03:41:17 UTC 2013


becuase i am stuck on this on an error (AttributeError: 'gr_hier_block2_sptr' object has no attribute 'set_callback') i decided to try to build again.  when trying to install the 4fsk demodulator i get this error:

make[2]: Entering directory `/home/matt/gr-fsk4/src/lib'
/usr/bin/swig -c++ -fvirtual -python -modern -I/usr/local/include/gnuradio/swig -I/usr/local/include/gnuradio   -module fsk4 -o fsk4.cc ../../src/lib/fsk4.i				
/usr/local/include/gnuradio/swig/gr_basic_block.i:26: Error: Unable to find 'pmt_swig.i'

note that when i run op25 the first output line is "Imported legacy fsk4".  so now i am confused as to how grc is importing the fsk4 if i cant even install it? 

Cheers,
Matt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20130303/b10f75ec/attachment.html>


More information about the op25-dev mailing list