[op25-dev] op25 New Install What version Of Ubuntu? What Version of GNURadio?

Andrewiski adevries at digitalexample.com
Mon Dec 10 03:43:16 UTC 2012


I am setting up an Ubuntu pc for the sole purpose of running op25.  I am struggling getting op25 to work on Ubuntu 12.10 as GCC 4.11 does not seem to be available to install anymore because it has compatibility issues with the newer version. At least that is what I have found on the web. 

Anyways I have the need to view raw p25 packets to trouble shoot a bug with a specific radio's data packets.

I have two ways to receive the audio stream either via discriminator tap or via usb rtl-sdr.  

In Ubuntu 12.10 I have done the following.

Failed to build GNURadio 3.2.2 with compiler errors, not missing imports but things like invalid syntax etc so preaty sure it is because I can't use Gcc 4.11 in Ubuntu 12.10

Successfully installed GNURadio 3.6 via builtin" Ubuntu Software Center" installer 
Successfully make and install op25 at least didn't get any errors.
Successfully make and install patched version of wireshark.
Successfully make gr-fsk4 but had to add stderr definitions to a couple of the files to fix make errors also had to copy gruel_common.i from /usr/local/include/gruel/swig to /usr/local/include/gnuradio/swig to fix missing gruel_common.i error
Succesfully make imbe_vocoder.

I tried to run "./audio_p25_rx.py –a" from the op25/python directory but kept getting an "importError: no module named op25" error.  I tired setting PYTHONPATH environment variable to /usr/local/lib/python2.7/dist-packages where the op25.py file was located (http://www.youtube.com/watch?v=86KtgkaH5H0) but still same error so I copied all of the op25/python/ files to /usr/local/lib/python2.7/dist-packages/gnuradio folder

I ran it there and still got op25 errors.

I figured it was an issue with gnuradio version so I uninstalled gnuradio using Ubuntu Software center.
I also did a "make uninstall" on the gr-fsk4 I installed earlier because it seems to have been replaced in op25 with gr-baz. 

gr-baz is included in this install script  
I did a build of gnuradio and a buch of other needed tools using a script located at (http://www.sbrac.org/files/build-gnuradio) 

I made a folder new folder src in my home directory I coped the build-gnuradio script to this folder.  I then ran chmod 755 build-gnuradio to allow execution.

I ran "./build-gnuradio –v all" (took awhile and had some warnings but no errors)

Now things started to work at least without the import errors so referenecs seem to be a lot better.

I can run ./rtl_sdr and do a capture so thats a plus as  I know my cheap sdr usb receiver is working.

If I run ./audio_p25_rx.py  I get the following errors

Using Volk machine: sse4_1_64
Traceback (most recent call last):
  File "./audio_p25_rx.py", line 1044, in <module>
    app = stdgui2.stdapp(p25_rx_block, "APCO P25 Receiver", 3)
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 38, in __init__
    wx.App.__init__ (self, redirect=False)
  File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7981, in __init__
    self._BootstrapApp()
  File "/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7555, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 42, in OnInit
    self._max_noutput_items)
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 64, in __init__
    self.panel = stdpanel (self, self, top_block_maker, max_nouts)
  File "/usr/local/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 86, in __init__
    self.top_block = top_block_maker (frame, self, vbox, sys.argv)
  File "./audio_p25_rx.py", line 97, in __init__
    self.__init_gui(frame, panel, vbox)
  File "./audio_p25_rx.py", line 276, in __init_gui
    self.spectrum_plotter = self.spectrum.win.plot
AttributeError: 'fft_window' object has no attribute 'plot'

If I open and execute (http://svn.spench.net/main/gr-baz/samples/OP25.grc) from http://wiki.spench.net/wiki/Gr-baz#grc I get the follow errors

Using Volk machine: sse4_1_64
Traceback (most recent call last):
  File "/home/andrewadevries/op25/op25_grc.py", line 563, in <module>
    tb = op25_grc()
  File "/home/andrewadevries/op25/op25_grc.py", line 306, in __init__
    self.rtl2832_source_0 = baz.rtl_source_c(defer_creation=True, output_size=gr.sizeof_gr_complex)
AttributeError: 'module' object has no attribute 'rtl_source_c'

Any one offer some suggestions?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20121210/161da0c7/attachment.html>


More information about the op25-dev mailing list