[op25-dev] gnuradio 3.6 or 3.2? || Re: "NameError: global name 'msgq' is not defined" ...

rajani_38 ramkumar.ramaswamy at gmail.com
Sat Aug 25 06:26:23 UTC 2012


I have the same error in usrp_p25_rx.py, and it occurs in the same segment of code - the one that sets up the decoder. In audio_p25_rx.py changing 'msgq' to 'self.msgq' worked in that it brought up the windows successfully. However, I'm not sure if this the best way to fix it permanently because (i) I would have to do it all over the place and deviate from the most recent codebase just to get it to run (ii) a couple of others have pointed this exact same error in 2012 and 2011 and it seems to have been resolved without changing the codebase.

Further, there are some deeper issues- for example, module usrpm cannot be found since the usrpm folder has been deprecated in gnuradio 3.6. So I really need to know if I am staring at a deeper issues in terms of needing to install gnuradio 3.2 rather than 3.6

rr at Pinky:~/SoftwareAndApps/op25/repeater/src/python$ ./scope.py
Traceback (most recent call last):
  File "./scope.py", line 46, in <module>
    from usrpm import usrp_dbid
ImportError: No module named usrpm

Any help would be appreciated. 

Thanks - Ram 

--- In op25-dev at yahoogroups.com, ikjtel <ikj1234i at ...> wrote:
>
> in line number 303 try editing the .py file and changing the value that's inside the parentheses - try changing it from 'msgq' to 'self.msgq'
> 
> Max
> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20120825/4152884e/attachment.html>


More information about the op25-dev mailing list