[op25-dev] Re: GRC blocks for OP25 and 4FSK missing

markop25 cottrell.m.a at gmail.com
Tue May 15 01:11:52 UTC 2012



Hi Steve,

I have been playing around for a while now using a few different ubuntu and debian distributions.  So far I've only had success with my 11.04 virtual machines.  I took some wireshark captures of some P25 samples running through Bob's flowgraph in both debian wheezy and ubuntu 11.04, the "good" capture (https://docs.google.com/open?id=0B8J3fNC5VR23akJ1Zl9xNkNHeHM) contains exactly what I would expect with correct NIDs, while the "bad" capture (https://docs.google.com/open?id=0B8J3fNC5VR23NlA2aGdWVDlHYUE) has packets with NIDs that are all zero with the occasional 1 in the LSB.  From the packets I glanced at, the data after the NID is the same in each capture.  

I have no idea what the differences are in the dependencies between my debian setup and ubuntu vm, but I have tried building in debian with gcc-4.5 and boost 1.46 (instead of gcc-4.6 and boost 1.49) and have not had any luck. I have also tried a few versions of gnuradio (3.4.2, 3.5.3 and 3.6.1) without any luck.  Any other ideas to help get it working or figure out the cause of the problem would be welcome.

Thanks,
Mark

--- In op25-dev at yahoogroups.com, Steve Glass <stevie.glass at ...> wrote:
>
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On 14/05/12 13:25, Richard Clarke wrote:
> >
> > A colleague of mine here has noted that op25 decoder seems to produce
> no audio when compiled and run on anything later than Ubuntu 11.04 for
> as yet undetermined reasons. Building and running on 11.10 or later
> (other mods required for 12.04) and you end up with the no audio
> problem. I've suggested that he post here with any more details he may have
> 
> I've used OP25 in different Ubuntu VMs and not had any problem in 11.10.
> Shall try 12.04 tonight. I think that I'll set the software decoder to
> be the default and that might help. There is a huge todo around the IMBE
> vocoder which I've been postponing but I'll start taking a look at that
> ASAP.
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.12 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAk+wf6wACgkQW7aAm65EWy4m9ACfeKcxeKLzlAttUm/btm5gICT0
> OdwAoNgc8sOx+KDvK1JSpf7PQmWMyLfQ
> =MufF
> -----END PGP SIGNATURE-----
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20120515/3601f327/attachment.html>


More information about the op25-dev mailing list