[op25-dev] Re: OP25 GRC - Almost but not quite working

Andy Knitt andyknitt at gmail.com
Thu Apr 26 02:55:36 UTC 2012


Honestly I'm not sure, it sounds like you're much more well-versed in Linux
than I am.  I installed it just to try this out.  I'm not able to run the
OP25 decoder from the command line either.  When I try to run
audio_p25_rx.py  I get an AttributeError 'fft_window' object has no
attribute 'plot'.  So I think I may have an OP25 issue, but not sure how to
solve it.  If it makes you feel any better there are at least three of us
having this same problem with the GRC block.

Andy

On Wed, Apr 25, 2012 at 9:48 PM, rrgsti <bobrich at gmail.com> wrote:

> **
>
>
> Hi Andy,
>
> I'm in the exact same boat. Using the RTL2832U dongle for the radio, I
> honestly wasn't expecting this to work for some reason, but the data coming
> in looks like it's getting decoded a bit. (I started this same question
> over on the RTL group but am going to try to solve it here as it may or may
> not have anything to do with the radio)
>
> I've got two theories at this moment.
>
> 1 - Balint's gnuradio patches in gr-baz are required for this to work, and
> the patches may or may not have taken against the latest gnuradio pulled
> from git as of a week ago or so.
>
> 2 - I'm having trouble getting all of the parts from the latest version of
> the OP25 project to build as well. It looks like there are some stale
> references to 'decoders' which is now called 'blocks', and am thinking I
> might need to go back a few revs. Something might be broken in there,
> preventing this from functioning as well.
>
> Would either of these possibly apply in your case as well?
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/op25-dev/attachments/20120425/90d8eb9d/attachment.html>


More information about the op25-dev mailing list