Change in libosmocore[master]: ns2: correct parse a BLOCK PDU which was received over a different NSVC

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

lynxis lazus gerrit-no-reply at lists.osmocom.org
Thu Sep 23 14:30:38 UTC 2021


lynxis lazus has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/25558 )

Change subject: ns2: correct parse a BLOCK PDU which was received over a different NSVC
......................................................................


Patch Set 1:

(6 comments)

This change is ready for review.

https://gerrit.osmocom.org/c/libosmocore/+/25558/1/src/gb/gprs_ns2_vc_fsm.c 
File src/gb/gprs_ns2_vc_fsm.c:

https://gerrit.osmocom.org/c/libosmocore/+/25558/1/src/gb/gprs_ns2_vc_fsm.c@375 
PS1, Line 375: 			/* the BLOCK ACK for foreign BLOCK PDUs (rx over another nsvc) will be send
> You can probably move this above, immediatelly below "ase GPRS_NS2_EV_RX_BLOCK:" and fall through.
I don't like the fallthrough here. IMHO it doesn't really help the readability.


https://gerrit.osmocom.org/c/libosmocore/+/25558/1/src/gb/gprs_ns2_vc_fsm.c@390 
PS1, Line 390: 			/* the block ack will be send by the rx NSVC */
> be sent
Done


https://gerrit.osmocom.org/c/libosmocore/+/25558/1/src/gb/gprs_ns2_vc_fsm.c@409 
PS1, Line 409: 			/* the block ack will be send by the rx NSVC */
> be sent
Done


https://gerrit.osmocom.org/c/libosmocore/+/25558/1/src/gb/gprs_ns2_vc_fsm.c@457 
PS1, Line 457: 		/* the BLOCK ACK for foreign BLOCK PDUs (rx over another nsvc) will be send
> be sent
Done


https://gerrit.osmocom.org/c/libosmocore/+/25558/1/src/gb/gprs_ns2_vc_fsm.c@459 
PS1, Line 459: 		if (event == GPRS_NS2_EV_RX_BLOCK)
> same, move above and fall through?
I don't like the fallthrough here.


https://gerrit.osmocom.org/c/libosmocore/+/25558/1/src/gb/gprs_ns2_vc_fsm.c@941 
PS1, Line 941: 		if (target_nsvc) {
> and from my previous post, you can also use always target_nsvc here. […]
I like to keep the fi as it is in the other messages.



-- 
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/25558
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I483e3a1d3b8c43bbb0cc6185b7f7f772bcb264bf
Gerrit-Change-Number: 25558
Gerrit-PatchSet: 1
Gerrit-Owner: lynxis lazus <lynxis at fe80.eu>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <dwillmann at sysmocom.de>
Gerrit-CC: pespin <pespin at sysmocom.de>
Gerrit-Comment-Date: Thu, 23 Sep 2021 14:30:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210923/699841f3/attachment.htm>


More information about the gerrit-log mailing list