Change in libosmocore[master]: Rename osmo dyn ts enums

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

pespin gerrit-no-reply at lists.osmocom.org
Thu Jul 1 16:12:44 UTC 2021


pespin has submitted this change. ( https://gerrit.osmocom.org/c/libosmocore/+/24784 )

Change subject: Rename osmo dyn ts enums
......................................................................

Rename osmo dyn ts enums

They will gain support to be activated as SDCCH/8 soon too. Since new
name would start to be too large, use a more generic naming for it.

Related: OS#5309
Change-Id: I56dcfe4d17899630b17f80145c3ced72f1e91e68
---
M include/osmocom/gsm/gsm_utils.h
M include/osmocom/gsm/protocol/gsm_12_21.h
M src/gsm/abis_nm.c
3 files changed, 7 insertions(+), 3 deletions(-)

Approvals:
  Jenkins Builder: Verified
  fixeria: Looks good to me, but someone else must approve
  dexter: Looks good to me, but someone else must approve
  pespin: Looks good to me, approved



diff --git a/include/osmocom/gsm/gsm_utils.h b/include/osmocom/gsm/gsm_utils.h
index 0909006..45af4f2 100644
--- a/include/osmocom/gsm/gsm_utils.h
+++ b/include/osmocom/gsm/gsm_utils.h
@@ -213,9 +213,11 @@
 	GSM_PCHAN_UNKNOWN,
 	GSM_PCHAN_CCCH_SDCCH4_CBCH,
 	GSM_PCHAN_SDCCH8_SACCH8C_CBCH,
-	GSM_PCHAN_TCH_F_TCH_H_PDCH,
+	GSM_PCHAN_OSMO_DYN,
 	_GSM_PCHAN_MAX
 };
+/* Backward compatibility with older naming: */
+#define GSM_PCHAN_TCH_F_TCH_H_PDCH GSM_PCHAN_OSMO_DYN
 
 /* Osmocom internal, not part of any gsm spec */
 enum gsm_chan_t {
diff --git a/include/osmocom/gsm/protocol/gsm_12_21.h b/include/osmocom/gsm/protocol/gsm_12_21.h
index 6156ce9..542d978 100644
--- a/include/osmocom/gsm/protocol/gsm_12_21.h
+++ b/include/osmocom/gsm/protocol/gsm_12_21.h
@@ -564,8 +564,10 @@
 	NM_CHANC_IPAC_TCHFull_PDCH = 0x80,
 	NM_CHANC_IPAC_TCHFull_TCHHalf = 0x81,
 	/* osmocom */
-	NM_CHANC_OSMO_TCHFull_TCHHalf_PDCH = 0x90,
+	NM_CHANC_OSMO_DYN = 0x90,
 };
+/* Backward compatibility with older naming: */
+#define NM_CHANC_OSMO_TCHFull_TCHHalf_PDCH NM_CHANC_OSMO_DYN
 
 /*! Event Type (Section 9.4.16) */
 enum abis_nm_event_type {
diff --git a/src/gsm/abis_nm.c b/src/gsm/abis_nm.c
index f7793d7..38cd194 100644
--- a/src/gsm/abis_nm.c
+++ b/src/gsm/abis_nm.c
@@ -703,7 +703,7 @@
 	[GSM_PCHAN_UNKNOWN]	= 0xff,
 	[GSM_PCHAN_CCCH_SDCCH4_CBCH]	= NM_CHANC_BCCH_CBCH,
 	[GSM_PCHAN_SDCCH8_SACCH8C_CBCH] = NM_CHANC_SDCCH_CBCH,
-	[GSM_PCHAN_TCH_F_TCH_H_PDCH]	= NM_CHANC_OSMO_TCHFull_TCHHalf_PDCH,
+	[GSM_PCHAN_OSMO_DYN]	= NM_CHANC_OSMO_DYN,
 	/* FIXME: bounds check */
 };
 

-- 
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/24784
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I56dcfe4d17899630b17f80145c3ced72f1e91e68
Gerrit-Change-Number: 24784
Gerrit-PatchSet: 2
Gerrit-Owner: pespin <pespin at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <dwillmann at sysmocom.de>
Gerrit-Reviewer: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: fixeria <vyanitskiy at sysmocom.de>
Gerrit-Reviewer: neels <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-CC: laforge <laforge at osmocom.org>
Gerrit-MessageType: merged
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210701/71f2f3c5/attachment.htm>


More information about the gerrit-log mailing list