Change in libosmocore[master]: ns2: Rename nsi->rate_ctr_idx to nsi->nsvc_rate_ctr_idx

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

laforge gerrit-no-reply at lists.osmocom.org
Sun Jan 31 11:35:09 UTC 2021


laforge has uploaded this change for review. ( https://gerrit.osmocom.org/c/libosmocore/+/22568 )


Change subject: ns2: Rename nsi->rate_ctr_idx to nsi->nsvc_rate_ctr_idx
......................................................................

ns2: Rename nsi->rate_ctr_idx to nsi->nsvc_rate_ctr_idx

We will soon get another of those indexes.

Change-Id: I68a2ef3b48097f524831dd04821824b21d6d1e18
---
M src/gb/gprs_ns2.c
M src/gb/gprs_ns2_internal.h
2 files changed, 4 insertions(+), 4 deletions(-)



  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/68/22568/1

diff --git a/src/gb/gprs_ns2.c b/src/gb/gprs_ns2.c
index f0fa038..95fec19 100644
--- a/src/gb/gprs_ns2.c
+++ b/src/gb/gprs_ns2.c
@@ -506,17 +506,17 @@
 	nsvc->sig_weight = 1;
 	nsvc->data_weight = 1;
 
-	nsvc->ctrg = rate_ctr_group_alloc(nsvc, &nsvc_ctrg_desc, bind->nsi->rate_ctr_idx);
+	nsvc->ctrg = rate_ctr_group_alloc(nsvc, &nsvc_ctrg_desc, bind->nsi->nsvc_rate_ctr_idx);
 	if (!nsvc->ctrg) {
 		goto err;
 	}
-	nsvc->statg = osmo_stat_item_group_alloc(nsvc, &nsvc_statg_desc, bind->nsi->rate_ctr_idx);
+	nsvc->statg = osmo_stat_item_group_alloc(nsvc, &nsvc_statg_desc, bind->nsi->nsvc_rate_ctr_idx);
 	if (!nsvc->statg)
 		goto err_group;
 	if (!ns2_vc_fsm_alloc(nsvc, id, initiater))
 		goto err_statg;
 
-	bind->nsi->rate_ctr_idx++;
+	bind->nsi->nsvc_rate_ctr_idx++;
 
 	llist_add(&nsvc->list, &nse->nsvc);
 	llist_add(&nsvc->blist, &bind->nsvc);
diff --git a/src/gb/gprs_ns2_internal.h b/src/gb/gprs_ns2_internal.h
index 1ab2770..8689f47 100644
--- a/src/gb/gprs_ns2_internal.h
+++ b/src/gb/gprs_ns2_internal.h
@@ -126,7 +126,7 @@
 	uint16_t timeout[NS_TIMERS_COUNT];
 
 	/*! workaround for rate counter until rate counter accepts char str as index */
-	uint32_t rate_ctr_idx;
+	uint32_t nsvc_rate_ctr_idx;
 
 	/*! libmnl netlink socket for link state monitoring */
 	struct osmo_mnl *linkmon_mnl;

-- 
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22568
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I68a2ef3b48097f524831dd04821824b21d6d1e18
Gerrit-Change-Number: 22568
Gerrit-PatchSet: 1
Gerrit-Owner: laforge <laforge at osmocom.org>
Gerrit-MessageType: newchange
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210131/112eaa4c/attachment.htm>


More information about the gerrit-log mailing list