Change in libosmocore[master]: gsm0808: use msgb_tv16_put() and osmo_store32be()

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

laforge gerrit-no-reply at lists.osmocom.org
Sat Feb 6 16:06:49 UTC 2021


laforge has submitted this change. ( https://gerrit.osmocom.org/c/libosmocore/+/22717 )

Change subject: gsm0808: use msgb_tv16_put() and osmo_store32be()
......................................................................

gsm0808: use msgb_tv16_put() and osmo_store32be()

This API makes the code simpler and easier to read.

Change-Id: Ibe9eaaa2a9344ba798631b8f115ad248f0a2f76b
---
M src/gsm/gsm0808.c
1 file changed, 5 insertions(+), 18 deletions(-)

Approvals:
  Jenkins Builder: Verified
  laforge: Looks good to me, approved
  pespin: Looks good to me, but someone else must approve



diff --git a/src/gsm/gsm0808.c b/src/gsm/gsm0808.c
index 971d962..6070ef3 100644
--- a/src/gsm/gsm0808.c
+++ b/src/gsm/gsm0808.c
@@ -494,8 +494,6 @@
 {
 	/* See also: 3GPP TS 48.008 3.2.1.1 ASSIGNMENT REQUEST */
 	struct msgb *msg;
-	uint16_t cic_sw;
-	uint32_t ci_sw;
 
 	/* Mandatory emelent! */
 	OSMO_ASSERT(ct);
@@ -513,11 +511,8 @@
 	gsm0808_enc_channel_type(msg, ct);
 
 	/* Circuit Identity Code 3.2.2.2  */
-	if (cic) {
-		cic_sw = osmo_htons(*cic);
-		msgb_tv_fixed_put(msg, GSM0808_IE_CIRCUIT_IDENTITY_CODE,
-				  sizeof(cic_sw), (uint8_t *) & cic_sw);
-	}
+	if (cic)
+		msgb_tv16_put(msg, GSM0808_IE_CIRCUIT_IDENTITY_CODE, *cic);
 
 	/* AoIP: AoIP Transport Layer Address (MGW) 3.2.2.102 */
 	if (ss) {
@@ -531,17 +526,9 @@
 	/* AoIP: Call Identifier 3.2.2.105 */
 	if (ci) {
 		/* NOTE: 3GPP TS 48.008, section 3.2.2.105 specifies that
-		   the least significant byte should be transmitted first.
-		   On x86, this would mean that the endieness is already
-		   correct, however a platform independed implementation
-		   is required: */
-#ifndef OSMO_IS_LITTLE_ENDIAN
-		ci_sw = osmo_swab32(*ci);
-#else
-		ci_sw = *ci;
-#endif
-		msgb_tv_fixed_put(msg, GSM0808_IE_CALL_ID, sizeof(ci_sw),
-				  (uint8_t *) & ci_sw);
+		 * the least significant byte shall be transmitted first. */
+		msgb_v_put(msg, GSM0808_IE_CALL_ID);
+		osmo_store32le(*ci, msgb_put(msg, sizeof(*ci)));
 	}
 
 	if (kc)

-- 
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22717
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: Ibe9eaaa2a9344ba798631b8f115ad248f0a2f76b
Gerrit-Change-Number: 22717
Gerrit-PatchSet: 3
Gerrit-Owner: fixeria <vyanitskiy at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge at osmocom.org>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-MessageType: merged
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210206/a757511d/attachment.htm>


More information about the gerrit-log mailing list