Change in libosmocore[master]: gsm48: add compare function for struct gprs_ra_id

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

daniel gerrit-no-reply at lists.osmocom.org
Thu Feb 4 09:27:01 UTC 2021


daniel has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmocore/+/22669 )

Change subject: gsm48: add compare function for struct gprs_ra_id
......................................................................


Patch Set 1:

(1 comment)

Thanks for taking this on!

https://gerrit.osmocom.org/c/libosmocore/+/22669/1/src/gsm/gsm48.c 
File src/gsm/gsm48.c:

https://gerrit.osmocom.org/c/libosmocore/+/22669/1/src/gsm/gsm48.c@1305 
PS1, Line 1305: int gsm48_compare_ra(const struct gprs_ra_id *raid1, const struct gprs_ra_id *raid2)
I think checking for equality like you did is okay in this case, but I would rename the function since compare usually returns an ordering of the arguments (<0/0/>0).

Something like gsm48_ra_equals() which returns true or false.

I think it would be even more useful to have a function that returns an enum indicating where a raid mismatched so you could use this function even if you only care about the lac.



-- 
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22669
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I4d7558c04d9d01761516526086be5104bb2eeada
Gerrit-Change-Number: 22669
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-CC: daniel <dwillmann at sysmocom.de>
Gerrit-Comment-Date: Thu, 04 Feb 2021 09:27:01 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210204/5efa72b5/attachment.htm>


More information about the gerrit-log mailing list