Change in libosmocore[master]: ns2: Rename nsi->rate_ctr_idx to nsi->nsvc_rate_ctr_idx

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

laforge gerrit-no-reply at lists.osmocom.org
Mon Feb 1 09:17:05 UTC 2021


laforge has submitted this change. ( https://gerrit.osmocom.org/c/libosmocore/+/22568 )

Change subject: ns2: Rename nsi->rate_ctr_idx to nsi->nsvc_rate_ctr_idx
......................................................................

ns2: Rename nsi->rate_ctr_idx to nsi->nsvc_rate_ctr_idx

We will soon get another of those indexes.

Change-Id: I68a2ef3b48097f524831dd04821824b21d6d1e18
---
M src/gb/gprs_ns2.c
M src/gb/gprs_ns2_internal.h
2 files changed, 4 insertions(+), 4 deletions(-)

Approvals:
  Jenkins Builder: Verified
  lynxis lazus: Looks good to me, approved



diff --git a/src/gb/gprs_ns2.c b/src/gb/gprs_ns2.c
index 2dde693..9c9da79 100644
--- a/src/gb/gprs_ns2.c
+++ b/src/gb/gprs_ns2.c
@@ -508,17 +508,17 @@
 	nsvc->sig_weight = 1;
 	nsvc->data_weight = 1;
 
-	nsvc->ctrg = rate_ctr_group_alloc(nsvc, &nsvc_ctrg_desc, bind->nsi->rate_ctr_idx);
+	nsvc->ctrg = rate_ctr_group_alloc(nsvc, &nsvc_ctrg_desc, bind->nsi->nsvc_rate_ctr_idx);
 	if (!nsvc->ctrg) {
 		goto err;
 	}
-	nsvc->statg = osmo_stat_item_group_alloc(nsvc, &nsvc_statg_desc, bind->nsi->rate_ctr_idx);
+	nsvc->statg = osmo_stat_item_group_alloc(nsvc, &nsvc_statg_desc, bind->nsi->nsvc_rate_ctr_idx);
 	if (!nsvc->statg)
 		goto err_group;
 	if (!ns2_vc_fsm_alloc(nsvc, id, initiater))
 		goto err_statg;
 
-	bind->nsi->rate_ctr_idx++;
+	bind->nsi->nsvc_rate_ctr_idx++;
 
 	llist_add(&nsvc->list, &nse->nsvc);
 	llist_add(&nsvc->blist, &bind->nsvc);
diff --git a/src/gb/gprs_ns2_internal.h b/src/gb/gprs_ns2_internal.h
index 4a899ed..f3c68f5 100644
--- a/src/gb/gprs_ns2_internal.h
+++ b/src/gb/gprs_ns2_internal.h
@@ -128,7 +128,7 @@
 	uint16_t timeout[NS_TIMERS_COUNT];
 
 	/*! workaround for rate counter until rate counter accepts char str as index */
-	uint32_t rate_ctr_idx;
+	uint32_t nsvc_rate_ctr_idx;
 
 	/*! libmnl netlink socket for link state monitoring */
 	struct osmo_mnl *linkmon_mnl;

-- 
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/22568
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I68a2ef3b48097f524831dd04821824b21d6d1e18
Gerrit-Change-Number: 22568
Gerrit-PatchSet: 3
Gerrit-Owner: laforge <laforge at osmocom.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: daniel <dwillmann at sysmocom.de>
Gerrit-Reviewer: laforge <laforge at osmocom.org>
Gerrit-Reviewer: lynxis lazus <lynxis at fe80.eu>
Gerrit-MessageType: merged
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210201/b5a85d85/attachment.htm>


More information about the gerrit-log mailing list