Change in osmo-pcu[master]: sched: Rename func to describe its used only for RLCMAC CTRL blocks

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

pespin gerrit-no-reply at lists.osmocom.org
Fri Apr 30 17:42:27 UTC 2021


pespin has submitted this change. ( https://gerrit.osmocom.org/c/osmo-pcu/+/23993 )

Change subject: sched: Rename func to describe its used only for RLCMAC CTRL blocks
......................................................................

sched: Rename func to describe its used only for RLCMAC CTRL blocks

Change-Id: I20e15047af2aac4d51e1dae263ab16e479bb0c46
---
M src/gprs_rlcmac_sched.cpp
1 file changed, 2 insertions(+), 2 deletions(-)

Approvals:
  laforge: Looks good to me, approved
  Jenkins Builder: Verified



diff --git a/src/gprs_rlcmac_sched.cpp b/src/gprs_rlcmac_sched.cpp
index 85c9be8..bb65ae1 100644
--- a/src/gprs_rlcmac_sched.cpp
+++ b/src/gprs_rlcmac_sched.cpp
@@ -41,7 +41,7 @@
 	struct gprs_rlcmac_ul_tbf *ul_ack;
 };
 
-static void get_tbf_candidates(const struct gprs_rlcmac_bts *bts, uint8_t trx,
+static void get_ctrl_msg_tbf_candidates(const struct gprs_rlcmac_bts *bts, uint8_t trx,
 			       uint8_t ts, struct tbf_sched_candidates *tbf_cand)
 {
 	struct gprs_rlcmac_ul_tbf *ul_tbf;
@@ -483,7 +483,7 @@
 	if (usf_tbf && req_mcs_kind == EGPRS && ms_mode(usf_tbf->ms()) != EGPRS)
 		req_mcs_kind = EGPRS_GMSK;
 
-	get_tbf_candidates(bts, trx, ts, &tbf_cand);
+	get_ctrl_msg_tbf_candidates(bts, trx, ts, &tbf_cand);
 
 	/* Prio 1: select control message */
 	if ((msg = sched_select_ctrl_msg(pdch, fn, block_nr, &tbf_cand))) {

-- 
To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/23993
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-Change-Id: I20e15047af2aac4d51e1dae263ab16e479bb0c46
Gerrit-Change-Number: 23993
Gerrit-PatchSet: 2
Gerrit-Owner: pespin <pespin at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge at osmocom.org>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-MessageType: merged
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20210430/332860c8/attachment.htm>


More information about the gerrit-log mailing list