Change in osmo-mgw[master]: mgcp_trunk: get rid of magic numbers for E1 slots

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

laforge gerrit-no-reply at lists.osmocom.org
Fri Nov 27 19:39:57 UTC 2020


laforge has submitted this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/21384 )

Change subject: mgcp_trunk: get rid of magic numbers for E1 slots
......................................................................

mgcp_trunk: get rid of magic numbers for E1 slots

use NUM_E1_TS-1 instead of 31 in relation of E1 timeslot count

Change-Id: I1cf5fa17f7455448a08ec3c32febca450eadb21e
---
M include/osmocom/mgcp/mgcp_trunk.h
1 file changed, 6 insertions(+), 2 deletions(-)

Approvals:
  Jenkins Builder: Verified
  laforge: Looks good to me, approved



diff --git a/include/osmocom/mgcp/mgcp_trunk.h b/include/osmocom/mgcp/mgcp_trunk.h
index 8127181..ba2c6c4 100644
--- a/include/osmocom/mgcp/mgcp_trunk.h
+++ b/include/osmocom/mgcp/mgcp_trunk.h
@@ -1,6 +1,7 @@
 #pragma once
 
 #include <osmocom/gsm/i460_mux.h>
+#include <osmocom/abis/e1_input.h>
 
 #define LOGPTRUNK(trunk, cat, level, fmt, args...) \
 LOGP(cat, level, "trunk:%u " fmt, \
@@ -59,8 +60,11 @@
 		/* E1 specific */
 		struct {
 			unsigned int vty_line_nr;
-			bool ts_in_use[31];
-			struct osmo_i460_timeslot i460_ts[31];
+			bool ts_in_use[NUM_E1_TS-1];
+			struct osmo_i460_timeslot i460_ts[NUM_E1_TS-1];
+			/* Note: on an E1 line TS 0 is devoted to framing and
+			 * alignment and therefore only NUM_E1_TS-1 timeslots
+			 * are available for traffic. */
 		} e1;
 	};
 };

-- 
To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/21384
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-mgw
Gerrit-Branch: master
Gerrit-Change-Id: I1cf5fa17f7455448a08ec3c32febca450eadb21e
Gerrit-Change-Number: 21384
Gerrit-PatchSet: 2
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <laforge at osmocom.org>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-MessageType: merged
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20201127/7fd95010/attachment.htm>


More information about the gerrit-log mailing list