Change in libosmo-abis[master]: add ipa ping/pong keepalive for OML/RSL links between bts and bsc

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

osmith gerrit-no-reply at lists.osmocom.org
Wed Jan 22 14:47:08 UTC 2020


osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/14743 )

Change subject: add ipa ping/pong keepalive for OML/RSL links between bts and bsc
......................................................................


Patch Set 11:

(6 comments)

https://gerrit.osmocom.org/c/libosmo-abis/+/14743/10/src/input/ipaccess.c 
File src/input/ipaccess.c:

https://gerrit.osmocom.org/c/libosmo-abis/+/14743/10/src/input/ipaccess.c@74 
PS10, Line 74: 	struct osmo_fsm_inst** ka_fsm;
> I don't see a point in using pointers to pointers here simply to have 3 shorter lines which fit anyw […]
Done


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/10/src/input/ipaccess.c@130 
PS10, Line 130: 	struct osmo_fsm_inst** ka_fsm;
> Again avoid this. If you want, catch any of this in a pointer:  […]
Done. Thanks for the suggestion with the macro; but now that the cleanup function exists, it doesn't even seem necessary.


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/10/src/input/ipaccess.c@262 
PS10, Line 262: 			ka_fsm = &ipaccess_line_ts(newbfd, new_line)->driver.ipaccess.ka_fsm;
> This chunk is mostly copied from the OML part above. […]
Done


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/10/src/input/ipaccess.c@304 
PS10, Line 304: 	struct osmo_fsm_inst** ka_fsm = &ipaccess_line_ts(bfd, line)->driver.ipaccess.ka_fsm;
> Same, avoid pointers to pointers for this kind of use.
Done


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/10/src/input/ipaccess.c@1045 
PS10, Line 1045: 		if (line->ipa_kap) {
> I see this chunk of code again and again. I'm sure it can go into a function.
Moved to new function ipaccess_keepalive_fsm_cleanup()... then realized later that you didn't mean the cleanup code above, but the part below. It doesn't hurt to have the cleanup code in a function though, it is used 4 times and saves a few lines.

Moved the conn_alloc_keepalive_fsm related code to new functions:
- ipaccess_bsc_keepalive_fsm_alloc
- ipaccess_bts_keepalive_fsm_alloc

(I had it in one function first, but with the differences in callbacks and alloc arguments, two functions seem more readable.)


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/10/src/input/ipaccess.c@1111 
PS10, Line 1111: 	if (line->ipa_kap) {
> Same chunk of code again.
Done



-- 
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/14743
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I30e3bd601e55355aaf738ee2f2c44c1ec2c46c6a
Gerrit-Change-Number: 14743
Gerrit-PatchSet: 11
Gerrit-Owner: Hoernchen <ewild at sysmocom.de>
Gerrit-Assignee: osmith <osmith at sysmocom.de>
Gerrit-Reviewer: Hoernchen <ewild at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: osmith <osmith at sysmocom.de>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-CC: fixeria <axilirator at gmail.com>
Gerrit-CC: laforge <laforge at osmocom.org>
Gerrit-Comment-Date: Wed, 22 Jan 2020 14:47:08 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200122/eacf49a1/attachment.htm>


More information about the gerrit-log mailing list