Change in libosmo-abis[master]: add ipa ping/pong keepalive for OML/RSL links between bts and bsc

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

osmith gerrit-no-reply at lists.osmocom.org
Wed Jan 22 10:50:21 UTC 2020


osmith has posted comments on this change. ( https://gerrit.osmocom.org/c/libosmo-abis/+/14743 )

Change subject: add ipa ping/pong keepalive for OML/RSL links between bts and bsc
......................................................................


Patch Set 9: -Code-Review

(4 comments)

Refactored as suggested by Pau.

Segfault is fixed now.

https://gerrit.osmocom.org/c/libosmo-abis/+/14743/8/src/e1_input_vty.c 
File src/e1_input_vty.c:

https://gerrit.osmocom.org/c/libosmo-abis/+/14743/8/src/e1_input_vty.c@189 
PS8, Line 189: 		line->ipa_kap = talloc_zero(line, struct ipa_keepalive_params);
> if you run "e1_line" on VTY twice -> memleak.
Good catch! Fixed.


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/8/src/e1_input_vty.c@199 
PS8, Line 199: ipakeepalive
> How about 'ipa-keepalive'?
Yes, that's easier to read. Changed.


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/8/src/input/ipaccess.c 
File src/input/ipaccess.c:

https://gerrit.osmocom.org/c/libosmo-abis/+/14743/8/src/input/ipaccess.c@65 
PS8, Line 65: 	int line_already_initialized;
> You are changing this to bool on next commit, better fix it here.
"int line_already_initialized" already existed before. That's why I put the change to bool in a separate patch. I've moved the int->bool patch before this one to make it clear.


https://gerrit.osmocom.org/c/libosmo-abis/+/14743/8/src/input/ipaccess.c@66 
PS8, Line 66: 	struct osmo_fsm_inst* ka_fsm[NUM_E1_TS];
> I have the feeling this should not be here but in struct e1i_ts.
Agreed. I've refactored the code accordingly and added a helper function to access e1i_ts from bfd and line.



-- 
To view, visit https://gerrit.osmocom.org/c/libosmo-abis/+/14743
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Change-Id: I30e3bd601e55355aaf738ee2f2c44c1ec2c46c6a
Gerrit-Change-Number: 14743
Gerrit-PatchSet: 9
Gerrit-Owner: Hoernchen <ewild at sysmocom.de>
Gerrit-Assignee: osmith <osmith at sysmocom.de>
Gerrit-Reviewer: Hoernchen <ewild at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: osmith <osmith at sysmocom.de>
Gerrit-CC: fixeria <axilirator at gmail.com>
Gerrit-CC: laforge <laforge at osmocom.org>
Gerrit-CC: pespin <pespin at sysmocom.de>
Gerrit-Comment-Date: Wed, 22 Jan 2020 10:50:21 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: pespin <pespin at sysmocom.de>
Comment-In-Reply-To: fixeria <axilirator at gmail.com>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200122/11c4393c/attachment.htm>


More information about the gerrit-log mailing list