Change in osmo-e1-hardware[master]: firmware: Rename fw_app.bin to icE1usb-fw.bin / e1_tracer-fw.bin

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

laforge gerrit-no-reply at lists.osmocom.org
Thu Dec 17 13:08:39 UTC 2020


laforge has submitted this change. ( https://gerrit.osmocom.org/c/osmo-e1-hardware/+/21755 )

Change subject: firmware: Rename fw_app.bin to icE1usb-fw.bin / e1_tracer-fw.bin
......................................................................

firmware: Rename fw_app.bin to icE1usb-fw.bin / e1_tracer-fw.bin

This is clearly much more descriptive, and avoids mixing up firmware
files for different boards

Change-Id: I319edb76dd74be6904395692ab1599fb8f1f9065
---
M firmware/ice40-riscv/e1-tracer/Makefile
M firmware/ice40-riscv/icE1usb/Makefile
2 files changed, 8 insertions(+), 8 deletions(-)

Approvals:
  laforge: Looks good to me, approved; Verified



diff --git a/firmware/ice40-riscv/e1-tracer/Makefile b/firmware/ice40-riscv/e1-tracer/Makefile
index 0c522a2..88b80d6 100644
--- a/firmware/ice40-riscv/e1-tracer/Makefile
+++ b/firmware/ice40-riscv/e1-tracer/Makefile
@@ -56,10 +56,10 @@
 	$(NULL)
 
 
-all: fw_app.bin
+all: e1_tracer-fw.bin
 
 
-fw_app.elf: $(LNK) $(HEADERS_app) $(SOURCES_app) $(HEADERS_common) $(SOURCES_common)
+e1_tracer-fw.elf: $(LNK) $(HEADERS_app) $(SOURCES_app) $(HEADERS_common) $(SOURCES_common)
 	$(CC) $(CFLAGS) -Wl,-Bstatic,-T,$(LNK),--strip-debug -o $@ $(SOURCES_common) $(SOURCES_app)
 
 
@@ -69,10 +69,10 @@
 %.bin: %.elf
 	$(OBJCOPY) -O binary $< $@
 
-prog: fw_app.bin
+prog: e1_tracer-fw.bin
 	$(ICEPROG) -o 640k $<
 
-dfuprog: fw_app.bin
+dfuprog: e1_tracer-fw.bin
 	$(DFU_UTIL) -R -a 1 -D $<
 
 
diff --git a/firmware/ice40-riscv/icE1usb/Makefile b/firmware/ice40-riscv/icE1usb/Makefile
index f2b1103..b830051 100644
--- a/firmware/ice40-riscv/icE1usb/Makefile
+++ b/firmware/ice40-riscv/icE1usb/Makefile
@@ -56,10 +56,10 @@
 	$(NULL)
 
 
-all: fw_app.bin
+all: icE1usb-fw.bin
 
 
-fw_app.elf: $(LNK) $(HEADERS_app) $(SOURCES_app) $(HEADERS_common) $(SOURCES_common)
+icE1usb-fw.elf: $(LNK) $(HEADERS_app) $(SOURCES_app) $(HEADERS_common) $(SOURCES_common)
 	$(CC) $(CFLAGS) -Wl,-Bstatic,-T,$(LNK),--strip-debug -o $@ $(SOURCES_common) $(SOURCES_app)
 
 
@@ -69,10 +69,10 @@
 %.bin: %.elf
 	$(OBJCOPY) -O binary $< $@
 
-prog: fw_app.bin
+prog: icE1usb-fw.bin
 	$(ICEPROG) -o 640k $<
 
-dfuprog: fw_app.bin
+dfuprog: icE1usb-fw.bin
 	$(DFU_UTIL) -R -a 1 -D $<
 
 

-- 
To view, visit https://gerrit.osmocom.org/c/osmo-e1-hardware/+/21755
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-e1-hardware
Gerrit-Branch: master
Gerrit-Change-Id: I319edb76dd74be6904395692ab1599fb8f1f9065
Gerrit-Change-Number: 21755
Gerrit-PatchSet: 1
Gerrit-Owner: laforge <laforge at osmocom.org>
Gerrit-Reviewer: laforge <laforge at osmocom.org>
Gerrit-MessageType: merged
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20201217/261c730c/attachment.htm>


More information about the gerrit-log mailing list