Change in osmo-ggsn[master]: Add default APN for each EUA Type

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

pespin gerrit-no-reply at lists.osmocom.org
Sat Apr 25 14:02:36 UTC 2020


pespin has posted comments on this change. ( https://gerrit.osmocom.org/c/osmo-ggsn/+/17941 )

Change subject: Add default APN for each EUA Type
......................................................................


Patch Set 4: Code-Review-1

(3 comments)

https://gerrit.osmocom.org/c/osmo-ggsn/+/17941/4/ggsn/ggsn.c 
File ggsn/ggsn.c:

https://gerrit.osmocom.org/c/osmo-ggsn/+/17941/4/ggsn/ggsn.c@458 
PS4, Line 458: 		if (pdp->eua.l < 2 || pdp->eua.v[0] != 0xf1)
> taken from lib/in46_addr. […]
Don't play with eua fields directly, it's cumbersome and difficult to follow. Better move "(num_addr = in46a_from_eua(&pdp->eua, addr)" block from line 459 up here and then use that to decide the default apn.

then:
switch (num_addr) {
  case 2:
     ... v4v6 default ...
  case 1:
     if(in46a_is_v4(&addr[0])
        ... v4 default ...
     else
        ... v6 default ...
  default:
     .... (check if in46a_from_eua can return 0 or negative and probably pdp reject here ....
        
}


https://gerrit.osmocom.org/c/osmo-ggsn/+/17941/4/ggsn/ggsn.c@486 
PS4, Line 486: 	if (pdp->eua.l > 2)
Also this needs to be moved up.


https://gerrit.osmocom.org/c/osmo-ggsn/+/17941/4/ggsn/ggsn_vty.c 
File ggsn/ggsn_vty.c:

https://gerrit.osmocom.org/c/osmo-ggsn/+/17941/4/ggsn/ggsn_vty.c@300 
PS4, Line 300: 	"default-apnv6 NAME",
> I agree the name is a bit odd, the dash would improve things. […]
Simply deprecated + redirect old default-apn NAME to be default-apn v4 NAME, and have the "default-apn (v4|v6|v4v6) NAME" that laforge suggested.

deprecate + redirect is already supported by some macro in libosmocore and we use that in some projects.



-- 
To view, visit https://gerrit.osmocom.org/c/osmo-ggsn/+/17941
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-ggsn
Gerrit-Branch: master
Gerrit-Change-Id: I03fcf8a1532bd9988ea99a6afd3dc325174ce9d6
Gerrit-Change-Number: 17941
Gerrit-PatchSet: 4
Gerrit-Owner: keith <keith at rhizomatica.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: keith <keith at rhizomatica.org>
Gerrit-Reviewer: pespin <pespin at sysmocom.de>
Gerrit-CC: laforge <laforge at osmocom.org>
Gerrit-Comment-Date: Sat, 25 Apr 2020 14:02:36 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: keith <keith at rhizomatica.org>
Comment-In-Reply-To: laforge <laforge at osmocom.org>
Gerrit-MessageType: comment
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20200425/d9ab10e4/attachment.htm>


More information about the gerrit-log mailing list