Change in osmo-sgsn[master]: gprs_gmm: send Service Reject when no PDP ctxs are available.

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

lynxis lazus gerrit-no-reply at lists.osmocom.org
Wed May 8 13:00:26 UTC 2019


lynxis lazus has posted comments on this change. ( https://gerrit.osmocom.org/13744 )

Change subject: gprs_gmm: send Service Reject when no PDP ctxs are available.
......................................................................


Patch Set 7:

(3 comments)

https://gerrit.osmocom.org/#/c/13744/7/src/gprs/gprs_gmm.c
File src/gprs/gprs_gmm.c:

https://gerrit.osmocom.org/#/c/13744/7/src/gprs/gprs_gmm.c@1618
PS7, Line 1618: 
              : bool pdp_status_has_no_active_nsapis(const uint8_t *pdp_status, const size_t pdp_status_len)
              : {
              : 	size_t i;
              : 	for (i = 0; i < pdp_status_len; i++)
              : 		if (pdp_status[i] != 0)
              : 			return false;
              : 
              : 	return true;
              : }
Can you rename it to pdp_status_has_active_nsapis?
It would also mean you have to swap the logic. A positive check is more readable as a negation check.


https://gerrit.osmocom.org/#/c/13744/7/src/gprs/gprs_gmm.c@1629
PS7, Line 1629: /* 3GPP TS 24.008 Section 4.7.13.4 Service request procedure not accepted by the
              :  * network. Returns true if MS has active PDP contexts in pdp_status but SGSN
              :  * has none */
              : bool ms_has_active_pdp_and_sgsn_has_none(struct sgsn_mm_ctx *mmctx,
              : 					 const uint8_t *pdp_status,
              : 					 const size_t pdp_status_len)
              : {
              : 	if (!llist_empty(&mmctx->pdp_list))
              : 		return false;
              : 
              : 	return !pdp_status_has_no_active_nsapis(pdp_status, pdp_status_len);
              : }
Can you remove this function. Doing another redirection of a function just for this single case seems to be confusing.
Or do you plan do add this check more often? If so I would like to rename this function to check_pdp_status()


https://gerrit.osmocom.org/#/c/13744/7/src/gprs/gprs_gmm.c@1935
PS7, Line 1935: ms_has_active_pdp_and_sgsn_has_none(ctx, pdp_status, pdp_status_len)
do a llist_empty(..) && pdp_status_has_active_nsapis()



-- 
To view, visit https://gerrit.osmocom.org/13744
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-sgsn
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: If610cbef17c25ec44e65d4f1b2340d102c560437
Gerrit-Change-Number: 13744
Gerrit-PatchSet: 7
Gerrit-Owner: Mykola Shchetinin <mykola at pentonet.com>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Mykola Shchetinin <mykola at pentonet.com>
Gerrit-Reviewer: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-Reviewer: lynxis lazus <lynxis at fe80.eu>
Gerrit-Comment-Date: Wed, 08 May 2019 13:00:26 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: No
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20190508/34f9bd8f/attachment.htm>


More information about the gerrit-log mailing list