Change in osmo-hlr[master]: USSD: fix routing to multiple MSC

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

osmith gerrit-no-reply at lists.osmocom.org
Mon Apr 8 11:58:24 UTC 2019


osmith has posted comments on this change. ( https://gerrit.osmocom.org/13479 )

Change subject: USSD: fix routing to multiple MSC
......................................................................


Patch Set 6:

(5 comments)

Thanks for the reviews, here's the next version.

https://gerrit.osmocom.org/#/c/13479/5/src/hlr_ussd.c
File src/hlr_ussd.c:

https://gerrit.osmocom.org/#/c/13479/5/src/hlr_ussd.c@175
PS5, Line 175: 
> let's take this ss->subscr from the top. […]
Updated the patch to have ss->vlr_number, and look it up once if it is empty (like the MT USSD case you have described). The timer is dropped again.

The MO USSD case depends on the libosmocore.git MSC HO GSUP messages patch (needs gsup->source_name), so I've kept it as follow up patch here:
https://gerrit.osmocom.org/#/c/osmo-hlr/+/13515/

(I've used vlr_number instead of vlr_name, because it is also called vlr_number in hlr_subscriber->vlr_number, and so we don't introduce yet another name for the same thing.)


https://gerrit.osmocom.org/#/c/13479/5/src/hlr_ussd.c@251
PS5, Line 251: OGP(DLGSUP, LOG
> thx
Done


https://gerrit.osmocom.org/#/c/13479/5/src/hlr_ussd.c@260
PS5, Line 260: 
> same here.
Done


https://gerrit.osmocom.org/#/c/13479/5/src/hlr_ussd.c@263
PS5, Line 263: 
> (ack, I have no good idea about naming here)
Changed to "SS/USSD".


https://gerrit.osmocom.org/#/c/13479/5/src/hlr_ussd.c@343
PS5, Line 343: 		ss_tx_error(ss, true, GSM0480_ERR_CODE_SYSTEM_FAILURE);
> (setting ss->subscr to point at local struct subscr becomes invalid memory as soon as the function e […]
Now I get it - it worked in your patch (#4), because you had set it to NULL afterwards. Thanks for explaining.



-- 
To view, visit https://gerrit.osmocom.org/13479
To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-hlr
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I18067bfadd33a6bc59a9ee336b6937313826fce3
Gerrit-Change-Number: 13479
Gerrit-PatchSet: 6
Gerrit-Owner: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder (1000002)
Gerrit-Reviewer: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Pau Espin Pedrol <pespin at sysmocom.de>
Gerrit-Reviewer: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Reviewer: osmith <osmith at sysmocom.de>
Gerrit-Comment-Date: Mon, 08 Apr 2019 11:58:24 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: No
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osmocom.org/pipermail/gerrit-log/attachments/20190408/bc117a63/attachment.htm>


More information about the gerrit-log mailing list