libosmocore[master]: Add functions for extended RACH coding

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Vadim Yanitskiy gerrit-no-reply at lists.osmocom.org
Tue Nov 28 18:20:22 UTC 2017


Patch Set 10: Code-Review-1

(3 comments)

https://gerrit.osmocom.org/#/c/5062/10/include/osmocom/coding/gsm0503_coding.h
File include/osmocom/coding/gsm0503_coding.h:

Line 66: int gsm0503_rach_ext_encode(ubit_t *burst, uint16_t ra, uint8_t bsic);
I would prefer to keep the coding API similar for both 8-bit
and 11-bit RACH. Like in case of the gsm0503_rach_encode():

... const uint16_t *ra11 ...


Line 67: int gsm0503_rach_ext_decode(uint16_t *ra, const sbit_t *burst, uint8_t bsic);
Here also would be better to rename 'ra' to 'ra11'.


https://gerrit.osmocom.org/#/c/5062/10/tests/coding/coding_test.c
File tests/coding/coding_test.c:

Line 165: 	if (ra != result)
May we use OSMO_ASSERT here?


-- 
To view, visit https://gerrit.osmocom.org/5062
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I85a34a82d5cd39a594ee89d91a2338226066ab5d
Gerrit-PatchSet: 10
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Reviewer: fixeria <axilirator at gmail.com>
Gerrit-Reviewer: tnt <tnt at 246tNt.com>
Gerrit-HasComments: Yes



More information about the gerrit-log mailing list