[MERGED] osmo-mgw[master]: cosmetic: rename bts_codec to codec_str

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Harald Welte gerrit-no-reply at lists.osmocom.org
Thu Nov 2 14:19:59 UTC 2017


Harald Welte has submitted this change and it was merged.

Change subject: cosmetic: rename bts_codec to codec_str
......................................................................


cosmetic: rename bts_codec to codec_str

make variable name more meaningful

e enter the commit message for your changes. Lines starting

Change-Id: I4d4d5af8925d032155ca1ef8c7d7d2e496a60fb6
---
M src/libosmo-mgcp/mgcp_sdp.c
1 file changed, 3 insertions(+), 3 deletions(-)

Approvals:
  Harald Welte: Looks good to me, approved
  Jenkins Builder: Verified



diff --git a/src/libosmo-mgcp/mgcp_sdp.c b/src/libosmo-mgcp/mgcp_sdp.c
index e6bf9c2..423153c 100644
--- a/src/libosmo-mgcp/mgcp_sdp.c
+++ b/src/libosmo-mgcp/mgcp_sdp.c
@@ -175,7 +175,7 @@
 static int is_codec_compatible(const struct mgcp_endpoint *endp,
 			       const struct sdp_rtp_map *codec)
 {
-	char *bts_codec;
+	char *codec_str;
 	char audio_codec[64];
 
 	if (!codec->codec_name)
@@ -185,8 +185,8 @@
 	 * GSM, GSM/8000 and GSM/8000/1 should all be compatible.. let's go
 	 * by name first.
 	 */
-	bts_codec = endp->tcfg->audio_name;
-	if (sscanf(bts_codec, "%63[^/]/%*d/%*d", audio_codec) < 1)
+	codec_str = endp->tcfg->audio_name;
+	if (sscanf(codec_str, "%63[^/]/%*d/%*d", audio_codec) < 1)
 		return 0;
 
 	return strcasecmp(audio_codec, codec->codec_name) == 0;

-- 
To view, visit https://gerrit.osmocom.org/4326
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I4d4d5af8925d032155ca1ef8c7d7d2e496a60fb6
Gerrit-PatchSet: 4
Gerrit-Project: osmo-mgw
Gerrit-Branch: master
Gerrit-Owner: dexter <pmaier at sysmocom.de>
Gerrit-Reviewer: Harald Welte <laforge at gnumonks.org>
Gerrit-Reviewer: Jenkins Builder



More information about the gerrit-log mailing list