[MERGED] osmo-trx[master]: sigProcLib: Rename demodulateBurst() to demodGmskBurst() for...

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Alexander Chemeris gerrit-no-reply at lists.osmocom.org
Wed Mar 22 18:33:13 UTC 2017


Alexander Chemeris has submitted this change and it was merged.

Change subject: sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
......................................................................


sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.

Change-Id: Ibcef8d7d4a2c06865bed7e4091ccc8dbbd494d77
---
M Transceiver52M/Transceiver.cpp
M Transceiver52M/sigProcLib.cpp
M Transceiver52M/sigProcLib.h
3 files changed, 6 insertions(+), 6 deletions(-)

Approvals:
  Tom Tsou: Looks good to me, approved
  Max: Looks good to me, but someone else must approve
  Jenkins Builder: Verified



diff --git a/Transceiver52M/Transceiver.cpp b/Transceiver52M/Transceiver.cpp
index 3df482f..3f624d0 100644
--- a/Transceiver52M/Transceiver.cpp
+++ b/Transceiver52M/Transceiver.cpp
@@ -583,7 +583,7 @@
   if (type == EDGE)
 	  return demodEdgeBurst(burst, mSPSRx, amp, toa);
 
-  return demodulateBurst(burst, mSPSRx, amp, toa);
+  return demodGmskBurst(burst, mSPSRx, amp, toa);
 }
 
 void writeToFile(radioVector *radio_burst, size_t chan)
diff --git a/Transceiver52M/sigProcLib.cpp b/Transceiver52M/sigProcLib.cpp
index 41b18cf..0a1fd44 100644
--- a/Transceiver52M/sigProcLib.cpp
+++ b/Transceiver52M/sigProcLib.cpp
@@ -2050,7 +2050,7 @@
  * 4 SPS (if activated) to minimize distortion through the fractional
  * delay filters. Symbol rotation and after always operates at 1 SPS.
  */
-SoftVector *demodulateBurst(signalVector &rxBurst, int sps,
+SoftVector *demodGmskBurst(signalVector &rxBurst, int sps,
                             complex channel, float TOA)
 {
   SoftVector *bits;
diff --git a/Transceiver52M/sigProcLib.h b/Transceiver52M/sigProcLib.h
index 87c0229..7dca71f 100644
--- a/Transceiver52M/sigProcLib.h
+++ b/Transceiver52M/sigProcLib.h
@@ -261,16 +261,16 @@
 signalVector *decimateVector(signalVector &wVector, size_t factor);
 
 /**
-        Demodulates a received burst using a soft-slicer.
-	@param rxBurst The burst to be demodulated.
+        Demodulates a GMSK burst using a soft-slicer.
+        @param rxBurst The burst to be demodulated.
         @param gsmPulse The GSM pulse.
         @param sps The number of samples per GSM symbol.
         @param channel The amplitude estimate of the received burst.
         @param TOA The time-of-arrival of the received burst.
         @return The demodulated bit sequence.
 */
-SoftVector *demodulateBurst(signalVector &rxBurst, int sps,
-                            complex channel, float TOA);
+SoftVector *demodGmskBurst(signalVector &rxBurst, int sps,
+                           complex channel, float TOA);
 
 /**
         Demodulate 8-PSK EDGE burst with soft symbol ooutput

-- 
To view, visit https://gerrit.osmocom.org/2137
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Ibcef8d7d4a2c06865bed7e4091ccc8dbbd494d77
Gerrit-PatchSet: 3
Gerrit-Project: osmo-trx
Gerrit-Branch: master
Gerrit-Owner: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Gerrit-Reviewer: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: Tom Tsou <tom at tsou.cc>



More information about the gerrit-log mailing list