[PATCH] libosmo-abis[master]: subchan_demux.c: rename llist_len() to _llist_len(), prep fo...

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Neels Hofmeyr gerrit-no-reply at lists.osmocom.org
Thu Jan 19 16:18:16 UTC 2017


Hello Max, Jenkins Builder,

I'd like you to reexamine a change.  Please visit

    https://gerrit.osmocom.org/1561

to look at the new patch set (#2).

subchan_demux.c: rename llist_len() to _llist_len(), prep for libosmocore llist_len()

Also change the return value to unsigned, like will be the case in the
libosmocore implementation; adjust the only caller.

Related: libosmocore Change-Id Ic49adc7a346f5722bf624d7d3b4a735e4220ae15
Change-Id: I99c627cf2a2f0dca1ec5d2ad36e3c3f7f0d8d191
---
M src/subchan_demux.c
1 file changed, 3 insertions(+), 3 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/libosmo-abis refs/changes/61/1561/2

diff --git a/src/subchan_demux.c b/src/subchan_demux.c
index f965490..7b3cb07 100644
--- a/src/subchan_demux.c
+++ b/src/subchan_demux.c
@@ -289,10 +289,10 @@
 	return i;
 }
 
-static int llist_len(struct llist_head *head)
+static unsigned int _llist_len(struct llist_head *head)
 {
 	struct llist_head *entry;
-	int i = 0;
+	unsigned int i = 0;
 
 	llist_for_each(entry, head)
 		i++;
@@ -327,7 +327,7 @@
 			int len)
 {
 	struct mux_subch *sch = &mx->subch[s_nr];
-	int list_len = llist_len(&sch->tx_queue);
+	unsigned int list_len = _llist_len(&sch->tx_queue);
 	struct subch_txq_entry *tqe = talloc_zero_size(tall_tqe_ctx,
 							sizeof(*tqe) + len);
 	if (!tqe)

-- 
To view, visit https://gerrit.osmocom.org/1561
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I99c627cf2a2f0dca1ec5d2ad36e3c3f7f0d8d191
Gerrit-PatchSet: 2
Gerrit-Project: libosmo-abis
Gerrit-Branch: master
Gerrit-Owner: Neels Hofmeyr <nhofmeyr at sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at sysmocom.de>



More information about the gerrit-log mailing list