libosmocore[master]: core/conv: add optimized Viterbi decoding

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

Vadim Yanitskiy gerrit-no-reply at lists.osmocom.org
Sun Nov 27 10:19:50 UTC 2016


Patch Set 4:

(7 comments)

The global question: should we use talloc here? As I know, a little performance leak takes place in case of talloc.

https://gerrit.osmocom.org/#/c/1337/4/src/viterbi.c
File src/viterbi.c:

Line 14:  * Lesser General Public License for more details.
Does this license compatible with libosmocore?


Line 326: 	trellis = (struct vtrellis *) calloc(1, sizeof(struct vtrellis));
Here we can use the static allocation too.


PS4, Line 426: if (dec->recursive)
             : 		_traceback_rec(dec, state, out, len);
             : 	else
             : 		_traceback(dec, state, out, len);
What to do with "_"?


Line 450: static struct vdecoder *alloc_vdec(const struct osmo_conv_code *code)
In case of static memory allocation, a better name for this function is "init_vdec".


Line 457: 	dec = (struct vdecoder *) calloc(1, sizeof(struct vdecoder));
I suggest to use static memory allocation here. One can be declared inside the scope of this file.

BTW: do we need to fill the structure by 0x00 here?


Line 539: static void _conv_decode(struct vdecoder *dec, const int8_t *seq, int _cnt)
Is there a more specific function name?


Line 564: 	reset_decoder(dec, term);
Maybe we could do it inside the init_vdec (current name: alloc_vdec)?


-- 
To view, visit https://gerrit.osmocom.org/1337
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74d355274b4176a7d924f91ef3c96912ce338fb2
Gerrit-PatchSet: 4
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Reviewer: Alexander Chemeris <Alexander.Chemeris at gmail.com>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Tom Tsou <tom at tsou.cc>
Gerrit-Reviewer: Vadim Yanitskiy <axilirator at gmail.com>
Gerrit-Reviewer: tnt <tnt at 246tNt.com>
Gerrit-HasComments: Yes



More information about the gerrit-log mailing list