libosmocore[master]: Add T.4 compression routines

This is merely a historical archive of years 2008-2021, before the migration to mailman3.

A maintained and still updated list archive can be found at https://lists.osmocom.org/hyperkitty/list/gerrit-log@lists.osmocom.org/.

prasadkg gerrit-no-reply at lists.osmocom.org
Tue Jul 5 11:47:48 UTC 2016


Patch Set 1:

> I agree with max. No need to have two routines. You can add an
 > "overload" (different name) and implement the old interface by
 > calling the new method?

 > 
 > Test cases are necessary and should be easy here. If the scenario
 > of the bitmap not fitting in the space reserved for the compressed
 > data then this should be tested as well.

I see that existing function is osmo_t4_encode(struct bitvec *bv) and new function is osmo_bitmap_compress (struct bitvec *rbb_vec,
uint16_t *ucmp_bmplen,uint8_t *cmp_bmplen, uint8_t *crbb_bitmap, uint16_t *uclen_crbb,uint16_t  max_bits).
First two parameters can be merged as bit vector, but changing  to have single argument will require significant changes to the implementation. Parameter max_bits (last parameter) is required to know when to stop encoding and uclen_crbb is required for the case of partial encoding of bitmap.

Function can be renamed as osmo_t4_encode (Overloaded function with different parameters)

Yes, we will add the test cases with different test vectors and resubmit.

-- 
To view, visit https://gerrit.osmocom.org/415
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Iae153d3639ea6b891c1fc10d7801a435c9492e26
Gerrit-PatchSet: 1
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: prasadkg <Prasad.Kaup at radisys.com>
Gerrit-Reviewer: Holger Freyther <holger at freyther.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Max <msuraev at sysmocom.de>
Gerrit-Reviewer: prasadkg <Prasad.Kaup at radisys.com>
Gerrit-HasComments: No



More information about the gerrit-log mailing list