From: gitosis@osmocom.org
Precedence: list
To: osmocom-commitlog@lists.osmocom.org
Date: Thu, 14 Nov 2013 09:41:30 GMT
Message-ID: <201311140941.rAE9fUpa093903@git.osmocom.org>
Subject: osmo-bts.git branch master updated. 0.3.0-69-ga82cc53
Message: 9

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Osmocom BTS-side code (Abis, scheduling, ...)".

The branch, master has been updated
       via  a82cc5321e841ab4ce17f1995a2cf7f2552a8217 (commit)
      from  897f97f6329d46e21fc80ea4bb2dfbfc11cf8123 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
http://cgit.osmocom.org/osmo-bts/commit/?id=a82cc5321e841ab4ce17f1995a2cf7f2552a8217

commit a82cc5321e841ab4ce17f1995a2cf7f2552a8217
Author: Holger Hans Peter Freyther <holger@moiji-mobile.com>
Date:   Thu Nov 14 10:39:08 2013 +0100

    rsl: Rename abis_rsl_sendmsg to avoid symbol clash with libosmo-abis
    
    Nicolas ended up with linker issues due abis_rsl_sendmsg being
    defined twice. Rename our version of the function and update the
    code.
    
    Patched with:
     @i@
     expression E;
     @@
    
     - abis_rsl_sendmsg(E)
     + abis_bts_rsl_sendmsg(E)

-----------------------------------------------------------------------

Summary of changes:
 include/osmo-bts/abis.h |  2 +-
 src/common/abis.c       |  2 +-
 src/common/rsl.c        | 38 +++++++++++++++++++-------------------
 3 files changed, 21 insertions(+), 21 deletions(-)


hooks/post-receive
-- 
Osmocom BTS-side code (Abis, scheduling, ...)


