Attention is currently required from: Hoernchen.
Patch set 2:Code-Review +2
6 comments:
Patchset:
The patch looks ok to me, but I think the comments are a bit short. At least this time it was hard to follow, even though the patch is actually very simple.
File tests/unittests/test_cat.py:
Patch Set #2, Line 34: def test_enabled_is_encodable(self):
maybe call this "test_encode_technology_enabled"
Patch Set #2, Line 35: """The flag used to have a bm of 0 so enabled -> 00 (that is disabled..)"""
I don't understand what a 'bm' (bit mask?) is, but I guess you refer to the state?
Patch Set #2, Line 40: def test_disabled_differs_from_enabled(self):
maybe call this "test_encode_technology_disabled"
Patch Set #2, Line 45: def test_state_byte_is_read_back_faithfully(self):
maybe call this "test_decode_technology", maybe then also assert on the technology ('eutran')?
Patch Set #2, Line 53: def test_multiple_technologies(self):
... then you could call this "test_decode_technology_multiple"
those are only suggestions, I don't want to block here.
To view, visit change 43559. To unsubscribe, or for help writing mail filters, visit settings.