Attention is currently required from: dexter, laforge.
dexter uploaded patch set #5 to this change.
The following approvals got outdated and were removed: Code-Review+1 by laforge, Verified+1 by Jenkins Builder
mnesia_db: split functionality into dedicated modules
The mnesia_db module is responsible to handle three different tables
with different scope. Let's split the functionality into separate
modules to make the code easier to maintain.
Change-Id: Ifc649337ab7ce7eb9dc602a1439293130f002f41
Related: SYS#8100
---
M doc/database.md
A include/mnesia_db_euicc.hrl
A include/mnesia_db_rest.hrl
A include/mnesia_db_work.hrl
M src/crypto_utils.erl
M src/esipa_asn1_handler.erl
M src/esipa_asn1_handler_utils.erl
M src/esipa_asn1_http_handler.erl
M src/esipa_rest_utils.erl
M src/mnesia_db.erl
A src/mnesia_db_euicc.erl
A src/mnesia_db_rest.erl
A src/mnesia_db_work.erl
M src/rest_handler.erl
14 files changed, 933 insertions(+), 857 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/onomondo-eim refs/changes/46/42946/5
To view, visit change 42946. To unsubscribe, or for help writing mail filters, visit settings.