Attention is currently required from: Hoernchen, fixeria, tnt.
6 comments:
File Transceiver52M/Transceiver.cpp:
Patch Set #4, Line 764: bi->rssi = (int8_t) lround(-(20.0 * log10(rxFullScale / avg) + rssi_offset));
so there's no nois calculation now? is it not used?BTW, I find this line quite difficult to read with all the operations, parenthesis and casts. Can you split it into a "float rssi = ..." and then "bi->rssi = (int8_t) lround(rssi);" or something like that?
Patch Set #4, Line 801: bi->toa256 = (int16_t) lround(ebp.toa * 256.0);
I wonder whether doing the multiplication before rounding is correct here. @tnt@246tNt.com and/or @ewild@sysmocom.de may want to review all these changes in this file.
Patch Set #4, Line 815: bi->burst, float_soft_bit_to_sbit);
Can you pass an inline static func to a std::transform?I also wonder whether the change from a loop in a function into a std:transform may hit somehow performance. Maybe it would be wise to do this change in a separate commit.
Patch Set #4, Line 1200: double noise_dbfs = 20.0 * log10(rxFullScale / mStates[chan].mNoiseLev) + rssi_offset;
aah noise calculation happens here now, it's only needed for logging, fine.
Patch Set #4, Line 1244: msgb_free(msg);
Since you are doing a synchrnonous write here: Why allocating and freeing a msgb every time? Can't you reuse it to avoid tons of mem allocating in the heap all the time?
Something like msgb_trim() or whatever, and keep the msgb inside the Transceiver object.
Patch Set #4, Line 1311: char command[64];
why was this changed? Looks like not really related to this patch or at least can be done in a separate patch?
To view, visit change 43115. To unsubscribe, or for help writing mail filters, visit settings.