Attention is currently required from: dexter, laforge.
4 comments:
File src/libmsc/sgs_iface.c:
Patch Set #2, Line 165: const uint8_t *mme_name_enc = TLVP_VAL_MINLEN(tp, SGSAP_IE_MME_NAME, SGS_MME_NAME_LEN);
so is the TLV value actually expected to be at least SGS_MME_NAME_LEN? Is that correct?
Patch Set #2, Line 173: if (TLVP_LEN(tp, SGSAP_IE_MME_NAME) > mme_name_len - 1)
"if (TLVP_LEN(tp, SGSAP_IE_MME_NAME) >= mme_name_len)" looks a lot easier to read to me but fine :)
Patch Set #2, Line 179: return 0;
I'd store TLVP_LEN(tp, SGSAP_IE_MME_NAME) in some len and add an extra mme_name[len] = '\0' here so that we make sure it ends up NULL terminated in this function.
Patch Set #2, Line 183: osmo_apn_to_str(mme_name, TLVP_VAL(tp, SGSAP_IE_MME_NAME), TLVP_LEN(tp, SGSAP_IE_MME_NAME));
isn't "TLVP_VAL(tp, SGSAP_IE_MME_NAME)" here just "mme_name_enc" ?
To view, visit change 43229. To unsubscribe, or for help writing mail filters, visit settings.