Attention is currently required from: laforge, pespin.
dexter uploaded patch set #4 to this change.
sgs_iface: clean up code in function decode_mme_name
The function decode_mme_name is a bit hard to read and also has
some minor problems we can optimize.
- Do not call TLVP_LEN each time we need the length of the
TLV IE. Call it once and keep the value in a variable.
- mme_name_enc holds the value part of the TLV IE, we can
use this variable instead of calling TLVP_VAL all all
the time.
- When we have copied the value part of the TLV IE using
memset, let's ensure that the string is terminated.
- Add/fix spec references.
Related: OS#7058
Change-Id: I9aec8300f15264b68ac8e7805e93e621b12cafb2
---
M src/libmsc/sgs_iface.c
1 file changed, 9 insertions(+), 4 deletions(-)
git pull ssh://gerrit.osmocom.org:29418/osmo-msc refs/changes/37/43237/4
To view, visit change 43237. To unsubscribe, or for help writing mail filters, visit settings.